summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjnanar2020-05-31 22:04:00 +0200
committerjnanar2020-05-31 22:04:00 +0200
commit8a6de891a843d84d94dd163ed04cf246e6cb96a4 (patch)
treed4de717219cb45514ba077fa674134fccb1df581
parentb751ecd179533d4facbfd0312cca8529dc5aee10 (diff)
downloadaur-8a6de891a843d84d94dd163ed04cf246e6cb96a4.tar.gz
FIX: missing dependencies and fix dbus-python faulty dependency.
The package still needs it but it is removing it in the setup.py because it trigger a bug that prevent sat to launch.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
2 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e55229ebf8f..9cfeb6936cdd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sat-xmpp-hg
pkgdesc = Salut à Toi, multi-frontends multi-purposes XMPP client (core)
- pkgver = 0.7.0.r3282.e7e7be79fbcd
+ pkgver = 0.7.0.r3289+.9057713ab124+
pkgrel = 1
url = http://salut-a-toi.org/
arch = any
@@ -14,7 +14,7 @@ pkgbase = sat-xmpp-hg
depends = python-pyopenssl
depends = python-dbus
depends = python-twisted
- depends = python-wokkel>=0.7.1
+ depends = python-wokkel-git
depends = python-xdg
depends = python-zope-interface
depends = mutagen
@@ -35,8 +35,11 @@ pkgbase = sat-xmpp-hg
depends = python-treq
depends = python-miniupnpc
depends = python-langid
+ depends = python-miniupnpc
+ depends = python-omemo-backend-signal
+ depends = python-omemo-syndace
+ depends = python-potr
optdepends = python-progressbar
- optdepends = python-potr
options = !strip
source = hg+https://repos.goffi.org/sat
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index c3bb4e672b63..611ce2f04eee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,14 @@
pkgname='sat-xmpp-hg'
_realname=sat
-pkgver=0.7.0.r3282.e7e7be79fbcd
+pkgver=0.7.0.r3289+.9057713ab124+
_version=0.7.0
pkgrel=1
url="http://salut-a-toi.org/"
pkgdesc="Salut à Toi, multi-frontends multi-purposes XMPP client (core)"
arch=('any')
-depends=('python' 'dbus' 'python-lxml' 'python-pillow' 'python-pyopenssl' 'python-dbus' 'python-twisted' 'python-wokkel>=0.7.1' 'python-xdg' 'python-zope-interface' 'mutagen' 'python-markdown' 'python-shortuuid-git' 'python-html2text' 'python-netifaces' 'python-service-identity' 'sat-tmp-hg' 'python-dateutil' 'python-regex' 'python-gobject' 'python-pyinotify' 'python-babel' 'python-urwid' 'python-urwid-satext-hg' 'python-xlib' 'python-treq' 'python-miniupnpc' 'python-langid')
-optdepends=('python-progressbar' 'python-potr')
+depends=('python' 'dbus' 'python-lxml' 'python-pillow' 'python-pyopenssl' 'python-dbus' 'python-twisted' 'python-wokkel-git' 'python-xdg' 'python-zope-interface' 'mutagen' 'python-markdown' 'python-shortuuid-git' 'python-html2text' 'python-netifaces' 'python-service-identity' 'sat-tmp-hg' 'python-dateutil' 'python-regex' 'python-gobject' 'python-pyinotify' 'python-babel' 'python-urwid' 'python-urwid-satext-hg' 'python-xlib' 'python-treq' 'python-miniupnpc' 'python-langid' 'python-miniupnpc' 'python-omemo-backend-signal' 'python-omemo-syndace' 'python-potr')
+optdepends=('python-progressbar')
makedepends=('python-setuptools' 'mercurial')
license=('AGPL3')
source=("hg+https://repos.goffi.org/sat")
@@ -24,6 +24,11 @@ pkgver() {
printf "$_version.r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
}
+prepare() {
+ cd "$srcdir/$_realname"
+ sed -i -e "s/'dbus-python',//" setup.py
+}
+
build() {
cd "$srcdir/$_realname"
python setup.py build