summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Szczuczko2015-08-23 17:08:23 +0100
committerAlex Szczuczko2015-08-23 17:22:07 +0100
commit19c5d462e9fe5269e12f51105fb8f0081e429d53 (patch)
treee5bf9a7dc82c1dbe5204bc86181626539e322ba3
downloadaur-19c5d462e9fe5269e12f51105fb8f0081e429d53.tar.gz
Inital package
-rw-r--r--.SRCINFO41
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD54
-rw-r--r--satellitereign-hib.desktop12
4 files changed, 112 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..757d04a8de3e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+pkgbase = satellitereign-hib
+ pkgdesc = Spiritual successor to the Syndicate games
+ pkgver = 093
+ pkgrel = 1
+ url = https://www.humblebundle.com/store/p/satellitereign_storefront
+ arch = i686
+ arch = x86_64
+ license = custom:commercial
+ options = !emptydirs
+ options = !strip
+ source = satellitereign-hib.desktop
+ source = SatelliteReignLinux093.zip::hib://SatelliteReignLinux093.zip
+ sha256sums = 87cc04b37e83a2871d4eb2aa694ea13eae2670fa364d4f06b823cf1c4323da33
+ sha256sums = 9d7ca804a73ee318319d464082439180ec700648807e9d23f1288a6555b7db64
+ depends_i686 = gcc-libs
+ depends_i686 = glibc
+ depends_i686 = libx11
+ depends_i686 = libxau
+ depends_i686 = libxcb
+ depends_i686 = libxcursor
+ depends_i686 = libxdmcp
+ depends_i686 = libxext
+ depends_i686 = libxfixes
+ depends_i686 = libxrandr
+ depends_i686 = libxrender
+ depends_i686 = libgl
+ depends_x86_64 = gcc-libs
+ depends_x86_64 = glibc
+ depends_x86_64 = libx11
+ depends_x86_64 = libxau
+ depends_x86_64 = libxcb
+ depends_x86_64 = libxcursor
+ depends_x86_64 = libxdmcp
+ depends_x86_64 = libxext
+ depends_x86_64 = libxfixes
+ depends_x86_64 = libxrandr
+ depends_x86_64 = libxrender
+ depends_x86_64 = libgl
+
+pkgname = satellitereign-hib
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1fb09e022f3a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.swp
+*.zip
+*.tar
+/src
+/pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..387e5affc8b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Alex Szczuczko <alex@szc.ca>
+
+pkgname=satellitereign-hib
+pkgver=093
+pkgrel=1
+pkgdesc="Spiritual successor to the Syndicate games"
+arch=("i686" "x86_64")
+url="https://www.humblebundle.com/store/p/satellitereign_storefront"
+license=("custom:commercial")
+depends_x86_64=("gcc-libs" "glibc" "libx11" "libxau" "libxcb" "libxcursor" "libxdmcp" "libxext" "libxfixes" "libxrandr" "libxrender" "libgl")
+depends_i686=("gcc-libs" "glibc" "libx11" "libxau" "libxcb" "libxcursor" "libxdmcp" "libxext" "libxfixes" "libxrandr" "libxrender" "libgl")
+options=("!emptydirs" "!strip")
+source=("${pkgname}.desktop"
+ "SatelliteReignLinux${pkgver}.zip::hib://SatelliteReignLinux${pkgver}.zip")
+sha256sums=("87cc04b37e83a2871d4eb2aa694ea13eae2670fa364d4f06b823cf1c4323da33"
+ "9d7ca804a73ee318319d464082439180ec700648807e9d23f1288a6555b7db64")
+
+# Disable compression of the package
+PKGEXT=".pkg.tar"
+
+package() {
+ # Binaries
+ if [ "$CARCH" = "x86_64" ]
+ then
+ install -Dm755 "$srcdir/SatelliteReignLinux$pkgver/SatelliteReignLinux.x86_64" "$pkgdir/opt/$pkgname/SatelliteReignLinux"
+ else
+ install -Dm755 "$srcdir/SatelliteReignLinux$pkgver/SatelliteReignLinux.x86" "$pkgdir/opt/$pkgname/SatelliteReignLinux"
+ fi
+
+ # Data
+ # Hardlink files to save the disk space and time spent copying them (they are large)
+ cp -Ral -t "$pkgdir/opt/$pkgname/" "$srcdir/SatelliteReignLinux$pkgver/SatelliteReignLinux_Data"
+ find "$pkgdir/opt/$pkgname/SatelliteReignLinux_Data" -type d -print0 | xargs -0 chmod 755
+ find "$pkgdir/opt/$pkgname/SatelliteReignLinux_Data" -type f -print0 | xargs -0 chmod 644
+
+ #
+ # System integration
+ #
+
+ # /bin
+ install -m755 -d "$pkgdir/usr/bin/"
+ ln -s "/opt/$pkgname/SatelliteReignLinux" "$pkgdir/usr/bin/$pkgname"
+
+ # License
+ # [None provided]
+
+ # Icon
+ install -m755 -d "$pkgdir/usr/share/pixmaps/"
+ ln -s "/opt/$pkgname/SatelliteReignLinux_Data/Resources/UnityPlayer.png" "$pkgdir/usr/share/pixmaps/${pkgname}.png"
+
+ # .desktop File
+ install -m755 -d "$pkgdir/usr/share/applications/"
+ install -m644 -t "$pkgdir/usr/share/applications/" "$srcdir/${pkgname}.desktop"
+}
diff --git a/satellitereign-hib.desktop b/satellitereign-hib.desktop
new file mode 100644
index 000000000000..f29d9e7e2061
--- /dev/null
+++ b/satellitereign-hib.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Icon=/usr/share/pixmaps/satellitereign-hib.png
+Exec=/usr/bin/satellitereign-hib
+Terminal=false
+StartupNotify=false
+
+Name=Satellite Reign
+Comment=Spiritual successor to the Syndicate games
+
+Categories=Game;