summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTD-Sky2023-12-07 18:30:26 +0800
committerTD-Sky2023-12-07 18:30:26 +0800
commit7c714bf0ff1cabcd81c6d0ad0f0e763ec4b94d94 (patch)
tree20449cf355092a8f0d81e0afe6fe20bd2d3839f9
parent930cdaf7bdb80ea805034959008651267b78da12 (diff)
downloadaur-7c714bf0ff1cabcd81c6d0ad0f0e763ec4b94d94.tar.gz
0.8.2-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 27 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc79cf79a868..f16f5a959645 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,15 @@
pkgbase = satty-bin
pkgdesc = A screenshot annotation tool inspired by Swappy and Flameshot
- pkgver = 0.8.1
+ pkgver = 0.8.2
pkgrel = 1
url = https://github.com/gabm/satty
arch = x86_64
license = MPL-2.0
+ depends = gtk4
+ depends = libadwaita
provides = satty
conflicts = satty
- source = https://github.com/gabm/satty/releases/download/v0.8.1/satty-v0.8.1-x86_64.tar.gz
- sha256sums = 1902268b51d6f6533483afadd0d321b9e56d7abf42bc9c7d045f6f43df6d6d40
+ source = satty-bin-0.8.2.tar.gz::https://github.com/gabm/satty/releases/download/v0.8.2/satty-x86_64-unknown-linux-gnu.tar.gz
+ sha256sums = 45201b6bdc3acd02f6a63e001d7619c26dd902850bc41349e6cab21163333d3b
pkgname = satty-bin
- depends = pango
- depends = glib2
- depends = cairo
- depends = libadwaita
- depends = gtk4
- depends = gdk-pixbuf2
diff --git a/PKGBUILD b/PKGBUILD
index f4c54d144b53..6774dccc5f59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,33 @@
-# Maintainer: Matthias Gabriel <gabm+aur@mailbox.org>
+# Maintainers:
+# - Matthias Gabriel <gabm+aur@mailbox.org>
+# - Collide <three-dim-sky@foxmail.com>
#
-# This PKGBUILD was generated by `cargo aur`: https://crates.io/crates/cargo-aur
+# https://github.com/TD-Sky/PKGBUILDs
pkgname=satty-bin
-pkgver=0.8.1
+pkgver=0.8.2
pkgrel=1
pkgdesc="A screenshot annotation tool inspired by Swappy and Flameshot"
url="https://github.com/gabm/satty"
license=("MPL-2.0")
arch=("x86_64")
-provides=("satty")
-conflicts=("satty")
-source=("https://github.com/gabm/satty/releases/download/v$pkgver/satty-v$pkgver-x86_64.tar.gz")
-sha256sums=("1902268b51d6f6533483afadd0d321b9e56d7abf42bc9c7d045f6f43df6d6d40")
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
+depends=('gtk4' 'libadwaita')
+source=("$pkgname-$pkgver.tar.gz::$url/releases/download/v$pkgver/${pkgname%-bin}-x86_64-unknown-linux-gnu.tar.gz")
+sha256sums=("45201b6bdc3acd02f6a63e001d7619c26dd902850bc41349e6cab21163333d3b")
package() {
- depends=('pango' 'glib2' 'cairo' 'libadwaita' 'gtk4' 'gdk-pixbuf2')
-
- mkdir -p "$pkgdir/usr/"
- cp -r . "$pkgdir/usr/"
+ install -Dm 755 "${pkgname%-bin}" -t "$pkgdir/usr/bin"
+ install -Dm 644 "completions/_${pkgname%-bin}" -t "$pkgdir/usr/share/zsh/site-functions"
+ install -Dm 644 "completions/${pkgname%-bin}.bash" "$pkgdir/usr/share/bash-completion/completions/${pkgname%-bin}"
+ install -Dm 644 "completions/${pkgname%-bin}.fish" -t "$pkgdir/usr/share/fish/vendor_completions.d"
+ install -Dm 644 "completions/${pkgname%-bin}.nu" -t "$pkgdir/usr/share/nushell/completions"
+ install -Dm 644 "completions/${pkgname%-bin}.elv" -t "$pkgdir/usr/share/elvish/lib"
+ install -Dm 644 "${pkgname%-bin}.desktop" -t "$pkgdir/usr/share/applications"
+ install -Dm 644 "assets/${pkgname%-bin}.svg" -t "$pkgdir/usr/share/icons/hicolor/scalable/apps"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/${pkgname%-bin}"
+ install -Dm 644 "assets/${pkgname%-bin}.svg" -t "$pkgdir/usr/share/doc/${pkgname%-bin}/assets"
+ install -Dm 644 assets/usage.gif -t "$pkgdir/usr/share/doc/${pkgname%-bin}/assets"
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/${pkgname%-bin}"
}