summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheDalaiAlpaca2021-11-05 14:51:21 +0100
committerTheDalaiAlpaca2021-11-05 14:51:21 +0100
commit62773b7a423cb5217346abd0a92078ab1b308cf1 (patch)
tree0b8054227badd80cabea5621b5ac97d682f2d929
downloadaur-62773b7a423cb5217346abd0a92078ab1b308cf1.tar.gz
Rename package saturnon-git to saturnon
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD26
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..388296eaf822
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = saturnon
+ pkgdesc = Treeview based file browser
+ pkgver = 0.40.2
+ pkgrel = 1
+ url = https://gitlab.com/TheDalaiAlpaca/saturnon
+ arch = any
+ license = GPL3
+ depends = bash>=4.2
+ depends = coreutils
+ depends = ncurses
+ depends = file
+ depends = util-linux
+ depends = grep
+ optdepends = less: for using saturnon to open textfiles
+ optdepends = vlc: for using saturnon with music.conf
+ optdepends = dbus: for using saturnon with music.conf
+ source = https://gitlab.com/TheDalaiAlpaca/saturnon/-/archive/0.40.2/saturnon-0.40.2.tar.gz
+ md5sums = SKIP
+
+pkgname = saturnon
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a2802300a66
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: TheDalaiAlpaca dleeg at tutanota dot com
+# Issues: https://gitlab.com/TheDalaiAlpaca/saturnon/-/issues
+
+_pkgname="saturnon"
+pkgname="$_pkgname"
+pkgver=0.40.2
+pkgrel=1
+pkgdesc="Treeview based file browser"
+arch=('any')
+url="https://gitlab.com/TheDalaiAlpaca/saturnon"
+license=('GPL3')
+depends=('bash>=4.2' 'coreutils' 'ncurses' 'file' 'util-linux' 'grep')
+optdepends=('less: for using saturnon to open textfiles'
+ 'vlc: for using saturnon with music.conf'
+ 'dbus: for using saturnon with music.conf')
+md5sums=(SKIP)
+source=("https://gitlab.com/TheDalaiAlpaca/$_pkgname/-/archive/$pkgver/$_pkgname-$pkgver.tar.gz")
+
+package() {
+ cd "$_pkgname-$pkgver"
+
+ install -Dm755 -t "$pkgdir/usr/bin" "saturnon"
+ install -Dm644 -t "$pkgdir/usr/share/man/man1" "saturnon.1"
+ install -Dm644 -t "$pkgdir/etc/saturnon" "conf/default.conf"
+ install -Dm644 -t "$pkgdir/etc/saturnon" "conf/music.conf"
+}