summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryozu2019-06-05 12:51:53 +0900
committeryozu2019-06-05 12:51:53 +0900
commit73bd4c5ad3d4a0308d9155f7199a72bc87dd862f (patch)
tree3f940ba160c7f7860b0d73d11b36d2dcb3c4d955
parent8135c3853c7f6eef401b39207a0fe7d719bd5f75 (diff)
downloadaur-73bd4c5ad3d4a0308d9155f7199a72bc87dd862f.tar.gz
Fix install process to adapt to the latest version.
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cf07951bb596..00c107aa9b6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=satysfi-git
_pkgname=SATySFi
-pkgver=r1420.f032f1a
+pkgver=r2148.e1e0270
pkgrel=1
pkgdesc='A statically-typed, functional typesetting system'
arch=('x86_64')
@@ -24,6 +24,9 @@ pkgver() {
build() {
cd "${_pkgname}"
+ sed -ie '/^LIBDIR=/d' install-libs.sh
+ sed -ie '2iLIBDIR=${pkgdir}/usr/share/satysfi' install-libs.sh
+ sed -ie 's/lib-satysfi/${srcdir}\/${_pkgname}\/lib-satysfi/' install-libs.sh
export OPAMROOT="${srcdir}/.opam"
export OPAMYES=1
opam init --no-setup
@@ -33,6 +36,7 @@ build() {
# bypass "ERROR: Preinstalled ocamlbuild detected at ..."
export CHECK_IF_PREINSTALLED=false
opam install --deps-only satysfi
+ ./download-fonts.sh
make PREFIX=/usr
make lib PREFIX=/usr
}
@@ -40,7 +44,6 @@ build() {
package() {
cd "${_pkgname}"
make install PREFIX="${pkgdir}/usr"
+ env srcdir="$srcdir" pkgdir="$pkgdir" _pkgname="$_pkgname" ./install-libs.sh
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- local gflpath=temp/latinmodern-math-1959/doc/GUST-FONT-LICENSE.txt
- install -Dm644 "${gflpath}" "${pkgdir}/usr/share/licenses/${pkgname}/latin-modern/GUST-FONT-LICENSE.txt"
}