summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaskie2018-03-04 22:15:28 +0900
committertaskie2018-03-04 22:15:28 +0900
commita620de6ac02c374b4be5ec802d4ffb7fe85ae415 (patch)
tree07d17d4801574d8ee8b0bfb4c74548fe40793eb4
parent45883345a3a9899f9e89b1ba84733c6dd2571f7d (diff)
downloadaur-a620de6ac02c374b4be5ec802d4ffb7fe85ae415.tar.gz
workaround for https://github.com/gfngfn/SATySFi/issues/46
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40513a89c10c..0e659bc37494 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = satysfi-git
pkgdesc = A statically-typed, functional typesetting system
- pkgver = r1314.3e6d067
+ pkgver = r1362.b88ae48
pkgrel = 1
url = https://github.com/gfngfn/SATySFi
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 19d0d952ae92..df773383a594 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,24 @@
pkgname=satysfi-git
_pkgname=SATySFi
-pkgver=r1314.3e6d067
+pkgver=r1362.b88ae48
pkgrel=1
-pkgdesc="A statically-typed, functional typesetting system"
+pkgdesc='A statically-typed, functional typesetting system'
arch=('x86_64')
-url="https://github.com/gfngfn/SATySFi"
+url='https://github.com/gfngfn/SATySFi'
license=('LGPL3')
depends=('glibc')
optdepends=()
makedepends=('git' 'libx11' 'ocaml-findlib' 'opam' 'rsync' 'wget')
-conflicts=("satysfi")
-provides=("satysfi")
+conflicts=('satysfi')
+provides=('satysfi')
options=()
source=("git+https://github.com/gfngfn/${_pkgname}")
md5sums=('SKIP')
pkgver() {
cd "${_pkgname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
@@ -28,16 +28,19 @@ build() {
export OPAMYES=1
opam init --no-setup
eval "$(opam config env)"
+ opam pin add jbuilder 1.0+beta17
opam pin add --no-action satysfi .
# bypass "ERROR: Preinstalled ocamlbuild detected at ..."
export CHECK_IF_PREINSTALLED=false
opam install --deps-only satysfi
- make lib
make PREFIX=/usr
+ make lib PREFIX=/usr
}
package() {
cd "${_pkgname}"
make install PREFIX="${pkgdir}/usr"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ local gflpath=temp/latinmodern-math-1959/doc/GUST-FONT-LICENSE.txt
+ install -Dm644 "${gflpath}" "${pkgdir}/usr/share/licenses/${pkgname}/latin-modern/GUST-FONT-LICENSE.txt"
}