summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgranitosaurus2018-04-25 09:29:32 +0000
committergranitosaurus2018-04-25 09:29:32 +0000
commit20018b827cb7186f8b736b0161517a58262be651 (patch)
treefaa2d4ad918fb99631da014ae76d35a8121e3d12
downloadaur-20018b827cb7186f8b736b0161517a58262be651.tar.gz
initial release
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD16
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0b675761661
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-sauth
+ pkgdesc = Simple, minimalistic http server with authentication written in python
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/Granitosaurus/sauth
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python
+ depends = python-setuptools
+ depends = python-click
+ source = https://github.com/Granitosaurus/sauth/archive/1.0.1.tar.gz
+ md5sums = a3982f16d9c006fa02c0d345ae7683b8
+
+pkgname = python-sauth
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..205caf142c9a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: Bernardas Ališauskas bernardas.ališauskas@protonmail.com
+pkgname=python-sauth
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Simple, minimalistic http server with authentication written in python"
+arch=(any)
+license=('GPL3')
+url="https://github.com/Granitosaurus/sauth"
+depends=('python' 'python-setuptools' 'python-click')
+makedepends=('python-setuptools')
+source=("https://github.com/Granitosaurus/sauth/archive/${pkgver}.tar.gz")
+md5sums=('a3982f16d9c006fa02c0d345ae7683b8')
+package() {
+ cd "${srcdir}/sauth-${pkgver}"
+ python setup.py install --root="${pkgdir}"
+}