summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2019-12-15 15:11:55 -0500
committerSlashbunny2019-12-15 15:11:55 -0500
commitaeee6d3f4f19617578de4301f3f071039a9ff995 (patch)
tree3561301e0668d6f65d0298a10507eb3d059ee6d7
parent748a91d1fc7f7d3c0a05fe2e2403324367cbec7d (diff)
downloadaur-aeee6d3f4f19617578de4301f3f071039a9ff995.tar.gz
Updated to 2.1.1.1 and savage2.net community-maintained version
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD22
3 files changed, 13 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e9cd7b587f1..730e4fb642ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
pkgbase = savage2
pkgdesc = Savage 2: A Tortured Soul is an fantasy themed online multiplayer team-based FPS/RTS/RPG hybrid. Completely free as of December 2008.
- pkgver = 2.1.0.8
+ pkgver = 2.1.1.1
pkgrel = 1
url = http://savage2.com/
install = savage2.install
- arch = i686
arch = x86_64
license = custom: "Savage 2"
makedepends = unzip
depends = mesa
depends = libxml2
- source = http://savage2.s2games.com/downloads/Savage2-2.1.0.8-linux-installer.run
+ depends = glu
+ source = http://masterserver1.talesofnewerth.com/download/Savage2-2.1.1.1-linux-x64-installer.run
source = savage2.launcher
source = savage2.desktop
source = s2editor.desktop
source = s2mviewer.desktop
source = savage2.sh
- md5sums = d049386d1f1fcc262c95275582a0dcd0
+ md5sums = 4826a5db0a6f8c6e8add2176c11c49e2
md5sums = f08e9499ff5f10b5e5e98454aa595db5
md5sums = a6957bb87da35d58df86d84a6dca1479
md5sums = b082a33fd1a580d3c70d80bbbfb0bffe
diff --git a/.gitignore b/.gitignore
index e4f398dc5b3a..af8b554edb8e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@ pkg/
*.pkg.tar.xz
*.pkg.tar
*.src.tar.gz
+Savage2-*-linux-x64-installer.run
diff --git a/PKGBUILD b/PKGBUILD
index 016b3b90a9ef..5a34e97aba8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,32 @@
-# Contributor: Slash <demodevil5 [at] yahoo [dot] com>
+# Maintainer: Slash <demodevil5 [at] yahoo [dot] com>
# Contributor: Ali H. Caliskan <ali.h.caliskan@gmail.com>
# Contributor: Xavier <shiningxc[at]gmail[dot]com>
pkgname=savage2
-pkgver=2.1.0.8
+pkgver=2.1.1.1
pkgrel=1
pkgdesc="Savage 2: A Tortured Soul is an fantasy themed online multiplayer team-based FPS/RTS/RPG hybrid. Completely free as of December 2008."
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='http://savage2.com/'
license=('custom: "Savage 2"')
-depends=('mesa' 'libxml2')
+depends=('mesa' 'libxml2' 'glu')
makedepends=('unzip')
install=savage2.install
-source=("http://savage2.s2games.com/downloads/Savage2-${pkgver}-linux-installer.run" \
+source=("http://masterserver1.talesofnewerth.com/download/Savage2-${pkgver}-linux-x64-installer.run" \
'savage2.launcher' 'savage2.desktop' 's2editor.desktop' 's2mviewer.desktop' 'savage2.sh')
-md5sums=('d049386d1f1fcc262c95275582a0dcd0'
+md5sums=('4826a5db0a6f8c6e8add2176c11c49e2'
'f08e9499ff5f10b5e5e98454aa595db5'
'a6957bb87da35d58df86d84a6dca1479'
'b082a33fd1a580d3c70d80bbbfb0bffe'
'177155e2c2c4e1382ce9b1343e26b5c7'
'4acf06412dbd5ebbec89d1c5f2c99b4f')
-[ "$CARCH" = "x86_64" ] && source[0]="http://savage2.s2games.com/downloads/Savage2-${pkgver}-linux-x64-installer.run"
-[ "$CARCH" = "x86_64" ] && md5sums[0]='e126bcfd808a785766a33231f40b066a'
PKGEXT='.pkg.tar'
package() {
cd "${srcdir}"
- # Installer name varies between architectures
- if [ "$CARCH" = "i686" ]; then
- _installer_name="Savage2-${pkgver}-linux-installer.run"
- else
- _installer_name="Savage2-${pkgver}-linux-x64-installer.run"
- fi
+ # Installer name
+ _installer_name="Savage2-${pkgver}-linux-x64-installer.run"
# Create Destination Directory
install -d "${pkgdir}/opt/savage2"