summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrent Carmer2018-06-01 09:33:30 -0700
committerBrent Carmer2018-06-01 09:33:30 -0700
commitff1552c64b294cc4968d2e0e30f8304968453701 (patch)
tree7e67309a937340f59f166bbddfcda1d8aaf68191
parent19c94372b4700216e28e5a4809ec10055fedea77 (diff)
downloadaur-ff1552c64b294cc4968d2e0e30f8304968453701.tar.gz
use latest
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff8acc8db8da..fa3cfc5a19c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri Jun 1 16:16:32 UTC 2018
+# Fri Jun 1 16:33:27 UTC 2018
pkgbase = saw-script-git
pkgdesc = The SAW scripting language.
pkgver = c3211c47
diff --git a/PKGBUILD b/PKGBUILD
index 976efaf03422..cf9310a2d6b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=saw-script-git
_pkgname=saw-script
-pkgver=0dbc21f1
+pkgver=c3211c47
pkgver() {
cd "$_pkgname"
git describe --long --tags --always | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
@@ -37,5 +37,5 @@ package() {
mkdir -p $pkgdir/usr/bin
cd $srcdir/$_pkgname
cp LICENSE $pkgdir/usr/share/licenses/$_pkgname
- find dist-newstyle -name "saw" -type f -exec ls -latR {} + | head -n1 | xargs -I{} cp {} $pkgdir/usr/bin
+ find dist-newstyle -name "saw" -type f -exec ls -latR {} + | head -n1 | perl -ne 'print ((split)[8])' | xargs -I{} cp {} $pkgdir/usr/bin
}