summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-09 00:34:59 +0200
committerStefan Husmann2015-06-09 00:34:59 +0200
commit97688c0be63865735a5d5e18db75affab9eb12fd (patch)
treec6b10468c42170bbe016c1fc350cf73e02edaf9b
downloadaur-97688c0be63865735a5d5e18db75affab9eb12fd.tar.gz
initial version
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD42
-rw-r--r--sawfish.install19
3 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4188291b7af3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = sawfish-git
+ pkgdesc = A window manager extensible using a Lisp-based scripting language.
+ pkgver = 1.11.27.gb642629
+ pkgrel = 1
+ url = http://sawfish.wikia.com
+ install = sawfish.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = gettext
+ makedepends = emacs
+ depends = libsm
+ depends = rep-gtk
+ depends = hicolor-icon-theme
+ depends = libxtst
+ depends = gtk2
+ optdepends = emacs: for using sawfish.el
+ provides = sawfish=1.11
+ conflicts = sawfish
+ options = !libtool
+ source = git://github.com/SawfishWM/sawfish.git
+ md5sums = SKIP
+
+pkgname = sawfish-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ac93d2f435f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Contributor: Thomas Dziedzic < gostrc at gmail >
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=sawfish-git
+pkgver=1.11.27.gb642629
+pkgrel=1
+pkgdesc='A window manager extensible using a Lisp-based scripting language.'
+arch=('i686' 'x86_64')
+url='http://sawfish.wikia.com'
+license=('GPL')
+depends=('libsm' 'rep-gtk' 'hicolor-icon-theme' 'libxtst' 'gtk2')
+makedepends=('git' 'gettext' 'emacs')
+optdepends=('emacs: for using sawfish.el')
+provides=('sawfish=1.11')
+conflicts=('sawfish')
+install=sawfish.install
+source=('git://github.com/SawfishWM/sawfish.git')
+options=('!libtool')
+md5sums=('SKIP')
+_gitname=sawfish
+
+pkgver() {
+ cd $_gitname
+ git describe --tags|sed 's/-/./g'
+}
+
+build() {
+ cd $_gitname
+ ./autogen.sh
+ ./configure --prefix=/usr --with-nls
+ make
+ emacs -batch -q -f batch-byte-compile sawfish.el
+}
+
+package() {
+ cd $_gitname
+ make DESTDIR="$pkgdir" install
+ install -Dm644 sawfish.el $pkgdir/usr/share/emacs/site-lisp/sawfish.el
+ install -Dm644 sawfish.elc $pkgdir/usr/share/emacs/site-lisp/sawfish.elc
+ install -Dm644 lisp/sawfish/wm/tile/readme.org \
+ $pkgdir/usr/share/doc/$pkgname/readme.tiling.org
+}
diff --git a/sawfish.install b/sawfish.install
new file mode 100644
index 000000000000..9e214f2d2222
--- /dev/null
+++ b/sawfish.install
@@ -0,0 +1,19 @@
+info_dir=/usr/share/info
+
+post_install() {
+ install-info ${info_dir}/sawfish.info.gz ${info_dir}/dir
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ install-info --delete ${info_dir}/sawfish.info.gz ${info_dir}/dir
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+