summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoron Behar2018-11-21 07:44:34 +0100
committerDoron Behar2018-11-21 07:45:01 +0100
commit3c22a4987d0eaf31768fbfe9de86a34a230a0642 (patch)
tree60bba89edc55eb2acf33508aa31bf9a7a6dc5dcd
downloadaur-3c22a4987d0eaf31768fbfe9de86a34a230a0642.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD36
-rw-r--r--tabs.patch25
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..284bb490da8e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = saws
+ pkgdesc = Scientific Application Web server
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://bitbucket.org/saws/saws/wiki/Home
+ arch = x86_64
+ arch = i686
+ license = MIT
+ source = https://bitbucket.org/saws/saws/get/v0.1.0.tar.gz
+ source = tabs.patch
+ md5sums = 941a541bdf625856be18c9752249146d
+ md5sums = aad46c722f9ab1ce5f73bf0b70c87be3
+
+pkgname = saws
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ffe10ea9681
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Doron Behar <doron.behar@gmail.com>
+
+pkgname=saws
+pkgver=0.1.0
+_commit=312ccc1698cf
+pkgrel=1
+pkgdesc="Scientific Application Web server"
+url="https://bitbucket.org/saws/saws/wiki/Home"
+arch=('x86_64' 'i686')
+license=('MIT')
+source=(
+ "https://bitbucket.org/saws/saws/get/v${pkgver}.tar.gz"
+ 'tabs.patch'
+)
+makedepends=()
+depends=()
+md5sums=('941a541bdf625856be18c9752249146d'
+ 'aad46c722f9ab1ce5f73bf0b70c87be3')
+
+prepare() {
+ cd ${srcdir}/saws-${pkgname}-${_commit}
+ patch -p0 < ../tabs.patch
+}
+
+build() {
+ cd ${srcdir}/saws-${pkgname}-${_commit}
+ ./configure \
+ --prefix=/usr \
+ --enable-shared
+ make
+}
+
+package() {
+ cd ${srcdir}/saws-${pkgname}-${_commit}
+ make DESTDIR=${pkgdir} install
+}
diff --git a/tabs.patch b/tabs.patch
new file mode 100644
index 000000000000..3b78a0af6ed2
--- /dev/null
+++ b/tabs.patch
@@ -0,0 +1,25 @@
+--- SAWsconf.py 2018-11-21 07:38:41.901082793 +0100
++++ - 2018-11-21 07:39:07.247628468 +0100
+@@ -1,9 +1,9 @@
+ try:
+- import argparse
++ import argparse
+ except:
+- import os
+- print('Installation of Python does not have argparse. Run "sudo easy_intall argparse" then try configure again')
+- os._exit(1)
++ import os
++ print('Installation of Python does not have argparse. Run "sudo easy_intall argparse" then try configure again')
++ os._exit(1)
+
+ def mkdir_p(path):
+ import os
+@@ -77,7 +77,7 @@
+ args = []
+ for i in sys.argv:
+ if i.find('=') > -1 and not i[0] == '-': i = '--'+i
+- args.extend([i])
++ args.extend([i])
+ sys.argv = args
+
+ parser = argparse.ArgumentParser(description='Configure Scientific Application Web server (SAWs)')