summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaolo2020-04-08 23:18:39 +0100
committerPaolo2020-04-08 23:18:39 +0100
commit0ca8197897860233dd8c44675e6018689f5859b5 (patch)
tree02f9b8036eaecc71edd2ca58b705a1dc3af45221
parent12cf2c442a0e8a3948d669adbf391817270c0602 (diff)
downloadaur-0ca8197897860233dd8c44675e6018689f5859b5.tar.gz
v1.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
-rw-r--r--sayit4
3 files changed, 15 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e418b5c08833..e44f96037e23 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = sayit
- pkgdesc = A text-to-speech command line tool that uses Azure Cognitive Services.
- pkgver = 0.3
- pkgrel = 3
+ pkgdesc = A text-to-speech command line tool backed by Azure Cognitive Services.
+ pkgver = 1.0
+ pkgrel = 1
url = https://github.com/pviotti/sayit
arch = any
license = MIT
depends = dotnet-runtime>=3.1.0
- source = https://github.com/pviotti/sayit/releases/download/v0.3/sayit-v0.3-linux.zip
+ source = https://github.com/pviotti/sayit/releases/download/v1.0/sayit-v1.0-linux.zip
source = sayit
- sha256sums = b04e5008cf9faad4c0fcefd0ba5b6c3569f6d4776422a01adfa212944f7bf427
- sha256sums = 13eb0778438f2468ae76f3ea4daf806cbe777ea907513f2c22470cd89a88e7fb
+ sha256sums = bd8f6c22a57d4640a806c40f8ae8fb45511054794e1be09f5c8e30a961ec2312
+ sha256sums = fb6b81e833a40374da84e396e8a4b97d40cea9289e1c952d94eac53cbe31e068
pkgname = sayit
diff --git a/PKGBUILD b/PKGBUILD
index db715aea5c61..7bd4b7b3386c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Paolo Viotti <skypixel@gmail.com>
pkgname=sayit
-pkgver=0.3
-pkgrel=3
-pkgdesc="A text-to-speech command line tool that uses Azure Cognitive Services."
+pkgver=1.0
+pkgrel=1
+pkgdesc="A text-to-speech command line tool backed by Azure Cognitive Services."
arch=('any')
url="https://github.com/pviotti/sayit"
license=('MIT')
depends=('dotnet-runtime>=3.1.0')
source=(https://github.com/pviotti/$pkgname/releases/download/v$pkgver/$pkgname-v$pkgver-linux.zip
$pkgname)
-sha256sums=('b04e5008cf9faad4c0fcefd0ba5b6c3569f6d4776422a01adfa212944f7bf427'
- '13eb0778438f2468ae76f3ea4daf806cbe777ea907513f2c22470cd89a88e7fb')
+sha256sums=('bd8f6c22a57d4640a806c40f8ae8fb45511054794e1be09f5c8e30a961ec2312'
+ 'fb6b81e833a40374da84e396e8a4b97d40cea9289e1c952d94eac53cbe31e068')
package() {
install -dm 755 "${pkgdir}/usr/share/$pkgname"
diff --git a/sayit b/sayit
index 0199ccc36b49..3e6c948a89b4 100644
--- a/sayit
+++ b/sayit
@@ -1,2 +1,6 @@
#!/bin/sh
+# The Speech SDK of Azure Cognitive Services is statically linked to OpenSSL
+# so it requires setting $SSL_CERT_DIR
+# https://docs.microsoft.com/en-us/azure/cognitive-services/speech-service/how-to-configure-openssl-linux
+export SSL_CERT_DIR=/etc/ssl/certs
exec /usr/share/sayit/SayIt "$@"