summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2020-08-28 00:43:11 +0200
committerFabioLolix2020-08-28 00:43:11 +0200
commitbe54de7a460945a8cf27b83997847ebda91cb938 (patch)
treed4a7a5d7e11e80cc24f44852b3005da892be4159
parent0e4c34f897e78d42dd75a56477c9b7d801e361e4 (diff)
downloadaur-be54de7a460945a8cf27b83997847ebda91cb938.tar.gz
revision, fix deps
-rw-r--r--.SRCINFO19
-rwxr-xr-xPKGBUILD55
2 files changed, 48 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a3da7b7f0c5..95eb2b373bcc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sayonara-player-git
- pkgdesc = Is a small, clear and fast audio player for Linux written in C++, supported by the Qt framework. It uses Gstreamer as audio backend.
- pkgver = 1.5.1_stable5
+ pkgdesc = Small, clear and fast audio player for Linux written in C++, supported by the Qt framework. It uses Gstreamer as audio backend.
+ pkgver = 1.6.0.beta6.r17.g21020349
pkgrel = 1
url = http://sayonara-player.com
arch = i686
@@ -8,18 +8,19 @@ pkgbase = sayonara-player-git
license = GPL3
makedepends = cmake
makedepends = qt5-tools
+ makedepends = qt5-svg
+ makedepends = git
+ makedepends = gst-plugins-bad
depends = qt5-base
depends = taglib
depends = gst-plugins-base
depends = gst-plugins-good
- depends = gst-plugins-bad
- depends = libmtp
- optdepends = lame
- optdepends = gst-plugins-ugly
- conflicts = sayonara-player-svn
+ optdepends = gst-libav: additional codecs
+ optdepends = gst-plugins-bad: additional codecs
+ optdepends = gst-plugins-ugly: additional codecs
+ provides = sayonara-player
conflicts = sayonara-player
- conflicts = sayonara-bin
- source = sayonara-player-git::git+https://git.sayonara-player.com/sayonara.git
+ source = git+https://gitlab.com/luciocarreras/sayonara-player.git
sha512sums = SKIP
pkgname = sayonara-player-git
diff --git a/PKGBUILD b/PKGBUILD
index f7fa656b6b2a..dc4f2319d2e8 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,50 @@
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
# Contributor: Fixed Torres <aur_linuxero@outlook.com>
-# Maintainer: Fixed Torres <aur_linuxero@outlook.com>
pkgname=sayonara-player-git
-pkgver=1.5.1_stable5
+pkgver=1.6.0.beta6.r17.g21020349
pkgrel=1
-pkgdesc="Is a small, clear and fast audio player for Linux written in C++, supported by the Qt framework. It uses Gstreamer as audio backend."
-arch=('i686' 'x86_64')
+pkgdesc="Small, clear and fast audio player for Linux written in C++, supported by the Qt framework. It uses Gstreamer as audio backend."
+arch=(i686 x86_64)
url="http://sayonara-player.com"
-license=('GPL3')
-depends=('qt5-base' 'taglib' 'gst-plugins-base' 'gst-plugins-good' 'gst-plugins-bad' 'libmtp')
-optdepends=('lame' 'gst-plugins-ugly')
-makedepends=('cmake' 'qt5-tools')
-conflicts=('sayonara-player-svn' 'sayonara-player' 'sayonara-bin')
-source=("${pkgname}::git+https://git.sayonara-player.com/sayonara.git")
+license=(GPL3)
+depends=(qt5-base taglib gst-plugins-base gst-plugins-good)
+makedepends=(cmake qt5-tools qt5-svg git gst-plugins-bad)
+optdepends=('gst-libav: additional codecs'
+ 'gst-plugins-bad: additional codecs'
+ 'gst-plugins-ugly: additional codecs')
+provides=(sayonara-player)
+conflicts=(sayonara-player)
+source=("git+https://gitlab.com/luciocarreras/sayonara-player.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ [[ -d build ]] || mkdir build
+}
build() {
- cd "$srcdir/$pkgname"
- mkdir build && cd build
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE="Release"
- make
+ cd "$srcdir/${pkgname%-git}/build"
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DUSE_SYSTEM_TAGLIB=1 \
+ -DWITH_TESTS=1
+ make
+}
+
+check() {
+ cd "$srcdir/${pkgname%-git}/build"
+ make test
}
package() {
- cd "$srcdir/$pkgname/build"
- make DESTDIR="$pkgdir/" install
+ cd "$srcdir/${pkgname%-git}/build"
+ make DESTDIR="$pkgdir/" install
}
-sha512sums=('SKIP')