summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonardKoenig2015-06-08 11:14:43 +0200
committerLeonardKoenig2015-06-08 11:14:43 +0200
commit6032c77693d1a5fc8dbff79102c218005db2f7f9 (patch)
tree07f52863034885599d31061cec79c2d8835902e6
downloadaur-6032c77693d1a5fc8dbff79102c218005db2f7f9.tar.gz
init
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD38
-rw-r--r--sayonara-player-svn.install8
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a2d70b7c65c8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = sayonara-player-svn
+ pkgdesc = Sayonara is a small, clear and fast audio player for Linux written in C++, supported by the Qt framework. It uses Gstreamer as audio backend.
+ pkgver = r1092
+ pkgrel = 2
+ url = https://sayonara-player.com/
+ install = sayonara-player-svn.install
+ arch = any
+ license = GPL3
+ makedepends = subversion
+ makedepends = cmake
+ depends = qt4
+ depends = curl
+ depends = taglib
+ depends = gst-plugins-base
+ depends = gst-plugins-good
+ depends = libnotify
+ optdepends = lame: mp3 converter, broadcasting
+ optdepends = gst-plugins-ugly: mp3 converter, broadcasting
+ conflicts = sayonara-player
+ source = sayonara-player-svn::svn+http://sayonara-player.com/svn/sayonara/trunk
+ md5sums = SKIP
+
+pkgname = sayonara-player-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0a6c78df92c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+#Maintainer: Leonard König <leonard dot r dot koenig at googlemail dot com>
+pkgname=sayonara-player-svn
+pkgver=r1092
+pkgrel=2
+pkgdesc="Sayonara is a small, clear and fast audio player for Linux written in C++, supported by the Qt framework. It uses Gstreamer as audio backend."
+arch=('any')
+url="https://sayonara-player.com/"
+license=('GPL3')
+depends=('qt4' 'curl' 'taglib' 'gst-plugins-base' 'gst-plugins-good' 'libnotify')
+optdepends=('lame: mp3 converter, broadcasting'
+ 'gst-plugins-ugly: mp3 converter, broadcasting')
+makedepends=('subversion' 'cmake')
+conflicts=('sayonara-player')
+install=sayonara-player-svn.install
+source=($pkgname::svn+http://sayonara-player.com/svn/sayonara/trunk)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ # workaround the reset of the svn-version...
+ local sver=$(svnversion)
+ local ver=$(($sver + 1042))
+ printf "r%s" "${ver//[[:alpha:]]}"
+}
+
+build() {
+# msg "$PWD"
+# msg "$pkgname"
+# msg "$ls"
+ cd "$pkgname"
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$SRCDEST/$pkgname"
+ make prefix=/usr DESTDIR="$pkgdir/" install
+}
diff --git a/sayonara-player-svn.install b/sayonara-player-svn.install
new file mode 100644
index 000000000000..d5c316566edc
--- /dev/null
+++ b/sayonara-player-svn.install
@@ -0,0 +1,8 @@
+post_upgrade() {
+ (( $(vercmp $2 1092) < 0 )) && cat <<MSG
+>>> The package now uses a workaround that adds 1042 to the revision number
+ as due to source-transfer the revision counter got reset.
+ So while the svn-revision is ~50, the actual version is much higher.
+MSG
+ true
+}