summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2015-06-13 17:59:23 +0200
committerMuflone2015-06-13 17:59:23 +0200
commitceba0554ae04c0a775f559c427bf25fa44e56ea4 (patch)
tree271b0aa340a2533e451ea15bd7f2c08c6bc8da8c
downloadaur-ceba0554ae04c0a775f559c427bf25fa44e56ea4.tar.gz
Initial import
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD56
-rw-r--r--move-sbin-to-bin.patch12
-rw-r--r--sbackup.conf5
-rw-r--r--sbackup.install23
5 files changed, 124 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..216e4a533085
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = sbackup
+ pkgdesc = Simple backup solution intended for desktop use
+ pkgver = 0.11.6
+ pkgrel = 2
+ url = https://launchpad.net/sbackup
+ install = sbackup.install
+ arch = any
+ license = GPL
+ makedepends = python2-distribute
+ depends = python2-gconf
+ depends = python2-libgnome
+ depends = python2-notify
+ depends = gvfs
+ depends = dbus-python
+ depends = hicolor-icon-theme
+ depends = xdg-utils
+ optdepends = python-pexpect: for ssh fuse plugin
+ optdepends = sshfs: for ssh plugin
+ optdepends = curlftpfs: for ftp and sftp fuse plugins
+ source = http://launchpad.net/sbackup/0.11/0.11.6/+download/sbackup_0.11.6.tar.gz
+ source = sbackup.conf
+ source = move-sbin-to-bin.patch
+ sha256sums = a7684837ac2dba199ae0e3a6e6af972b0ef328db0bb79c847e289e4c6418887d
+ sha256sums = d354338c794088c3e7c62162c414394bee339f05535f2316d00bc19c0f1af9b9
+ sha256sums = a0e7302d5053b44e36439d45e954c89689c0f826761c3bae8fdbd67037a54d43
+
+pkgname = sbackup
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b4ee5d38dc9a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+# Contributor: György Balló <ballogy@freestart.hu>
+# Contributor: Travis Willard <travisw@wmpub.ca>
+# Contributor: William Rea <sillywilly@gmail.com>
+
+pkgname=sbackup
+pkgver=0.11.6
+pkgrel=2
+pkgdesc="Simple backup solution intended for desktop use"
+arch=('any')
+url="https://launchpad.net/sbackup"
+license=('GPL')
+depends=('python2-gconf' 'python2-libgnome' 'python2-notify' 'gvfs' 'dbus-python' 'hicolor-icon-theme' 'xdg-utils')
+makedepends=('python2-distribute')
+optdepends=('python-pexpect: for ssh fuse plugin'
+ 'sshfs: for ssh plugin'
+ 'curlftpfs: for ftp and sftp fuse plugins')
+install="${pkgname}.install"
+source=("http://launchpad.net/${pkgname}/${pkgver%.*}/${pkgver}/+download/${pkgname}_${pkgver}.tar.gz"
+ "sbackup.conf"
+ "move-sbin-to-bin.patch")
+sha256sums=('a7684837ac2dba199ae0e3a6e6af972b0ef328db0bb79c847e289e4c6418887d'
+ 'd354338c794088c3e7c62162c414394bee339f05535f2316d00bc19c0f1af9b9'
+ 'a0e7302d5053b44e36439d45e954c89689c0f826761c3bae8fdbd67037a54d43')
+
+prepare() {
+ patch -p0 -i "../move-sbin-to-bin.patch"
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ find . -type f | xargs sed -i 's@^#!.*python$@#!/usr/bin/env python2@'
+ sed -i "s/dpkg --get-selections/pacman -Q/" src/sbackup/core/snapshot.py
+
+ make PYTHON=python2 PREFIX=/usr
+}
+
+package() {
+ # Add configuration file to tmpfiles.d
+ install -m755 -d "${pkgdir}/usr/lib/tmpfiles.d"
+ install -m644 -t "${pkgdir}/usr/lib/tmpfiles.d" "sbackup.conf"
+
+ # Install package files
+ cd "${pkgname}-${pkgver}"
+ make PYTHON=python2 \
+ PREFIX=/usr \
+ DESTDIR="${pkgdir}/usr" \
+ sysconf_dir=${pkgdir}/etc \
+ SETUP.PY_OPTS="--root=${pkgdir}/" \
+ DISABLE_MAKEFILE_GTK_UPDATE_ICON_CACHE=1 \
+ DISABLE_MAKEFILE_DESKTOP_DATABASE_RELOAD=1 \
+ DISABLE_MAKEFILE_DBUS_RELOAD=1 \
+ GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 \
+ DISABLE_MAKEFILE_CLEAN_DATA=1 \
+ install
+}
diff --git a/move-sbin-to-bin.patch b/move-sbin-to-bin.patch
new file mode 100644
index 000000000000..081f71672098
--- /dev/null
+++ b/move-sbin-to-bin.patch
@@ -0,0 +1,12 @@
+diff -Naur sbackup-0.11.6.orig/Makefile sbackup-0.11.6/Makefile
+--- sbackup-0.11.6.orig/Makefile 2013-09-17 20:49:58.000000000 +0200
++++ sbackup-0.11.6/Makefile 2015-01-14 11:44:12.630963188 +0100
+@@ -47,7 +47,7 @@
+
+ datadir=$(DESTDIR)/share
+ bindir=$(DESTDIR)/bin
+-sbindir=$(DESTDIR)/sbin
++sbindir=$(DESTDIR)/bin
+
+ libdir=$(datadir)/$(PKGNAME)
+ helpdir=$(datadir)/gnome/help/$(PKGNAME)
diff --git a/sbackup.conf b/sbackup.conf
new file mode 100644
index 000000000000..11b9cca5e10f
--- /dev/null
+++ b/sbackup.conf
@@ -0,0 +1,5 @@
+# systemd tmpfile settings for sbackup
+# See tmpfiles.d(5) for details
+
+d /var/lock/sbackup 0777 root root -
+
diff --git a/sbackup.install b/sbackup.install
new file mode 100644
index 000000000000..fb8cea4a77c9
--- /dev/null
+++ b/sbackup.install
@@ -0,0 +1,23 @@
+pkgname=apps_sbackup_global-preferences
+
+post_install() {
+ gconfpkg --install $pkgname
+ xdg-icon-resource forceupdate
+ sbackupconfig
+}
+
+pre_upgrade() {
+ pre_remove $1
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ gconfpkg --uninstall $pkgname
+}
+
+post_remove() {
+ xdg-icon-resource forceupdate
+}