summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorghollisjr2021-06-16 07:00:13 -0400
committerghollisjr2021-06-16 07:00:13 -0400
commitc52ec6785bebeca2f6644a5297315bc200f7f6a9 (patch)
tree8fc77892a8cde36260fdf8abb5c2ef76b8d1cf0c
downloadaur-c52ec6785bebeca2f6644a5297315bc200f7f6a9.tar.gz
First commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD62
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20cc0d07682f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = sbcl-git
+ pkgdesc = SBCL from project GIT repo
+ pkgver = 1.0
+ pkgrel = 1
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = automake
+ depends = gcc
+ depends = sbcl
+ provides = sbcl
+ conflicts = sbcl
+
+pkgname = sbcl-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1bb090071dba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# See http://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines
+# for more information on packaging from GIT sources.
+
+# Maintainer: Gary Hollis <ghollisjr@gmail.com>
+pkgname=sbcl-git
+pkgver=1.0
+pkgrel=1
+pkgdesc="SBCL from project GIT repo"
+arch=(any)
+url=""
+license=('GPL')
+groups=()
+depends=(automake gcc sbcl)
+makedepends=('git')
+provides=(sbcl)
+conflicts=(sbcl)
+replaces=()
+backup=()
+options=()
+install=
+source=()
+noextract=()
+md5sums=() #generate with 'makepkg -g'
+
+_gitroot=https://git.code.sf.net/p/sbcl/sbcl
+_gitname=sbcl-sbcl
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+
+ #
+ # BUILD HERE
+ #
+ sh make.sh
+}
+
+package() {
+ cd "$srcdir/$_gitname-build"
+ INSTALL_ROOT="$pkgdir/" ./install.sh
+}
+
+# vim:set ts=2 sw=2 et: