aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCorey Hinshaw2020-05-16 10:04:48 -0400
committerCorey Hinshaw2020-05-16 10:04:48 -0400
commit4d9d8137126c8df37484fb4624adde8a44db04b9 (patch)
treeccde0c67039bca8a47d8b7da64a6359455451d72
parentda63475e3c976a79a44130724268c368c5aa76e6 (diff)
downloadaur-4d9d8137126c8df37484fb4624adde8a44db04b9.tar.gz
Add DB.auth and KEK.auth generation
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rwxr-xr-xsbkeys6
3 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f76ff7dafba..370ae064ecbd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sbkeys
pkgdesc = Simple script to generate Secure Boot keys
- pkgver = 0.1.0
+ pkgver = 1.0.0
pkgrel = 1
url = https://github.com/electrickite/sbkeys
arch = any
@@ -11,7 +11,7 @@ pkgbase = sbkeys
depends = python2
depends = openssl
source = sbkeys
- sha256sums = f64107a1539c7f397386eb3b748f3c5d95965f3dad3bd5876d9ef8a101223c1b
+ sha256sums = a6d7a5fbdd62a07423ef9641e30bb177746720801462f84636c27096926c2d42
pkgname = sbkeys
diff --git a/PKGBUILD b/PKGBUILD
index c30c3d50f367..e55b3590e009 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
-# Maintainer: Corey Hinshaw <coreyhinshaw@gmail.com>
+# Maintainer: Corey Hinshaw <corey(at)electrickite(dot)org>
pkgname=sbkeys
-pkgver=0.1.0
+pkgver=1.0.0
pkgrel=1
pkgdesc="Simple script to generate Secure Boot keys"
arch=('any')
url="https://github.com/electrickite/sbkeys"
license=('GPL3')
depends=('efitools' 'coreutils' 'bash' 'python2' 'openssl')
-source=('sbkeys')
-sha256sums=('f64107a1539c7f397386eb3b748f3c5d95965f3dad3bd5876d9ef8a101223c1b')
+source=('sbkeys')
+sha256sums=('a6d7a5fbdd62a07423ef9641e30bb177746720801462f84636c27096926c2d42')
package() {
install -Dm755 sbkeys "${pkgdir}/usr/bin/sbkeys"
diff --git a/sbkeys b/sbkeys
index 63620d28b3b8..161605e45337 100755
--- a/sbkeys
+++ b/sbkeys
@@ -16,7 +16,7 @@
# along with this program. If not, see <http://www.gnu.org/licenses/>.
# Do not create new keys if key files already exist
-KEYS="PK.key PK.crt KEK.key KEK.crt DB.key DB.crt PK.cer KEK.cer DB.cer myGUID.txt PK.esl KEK.esl DB.esl noPK.esl PK.auth noPK.auth"
+KEYS="PK.key PK.crt KEK.key KEK.crt DB.key DB.crt PK.cer KEK.cer DB.cer myGUID.txt PK.esl KEK.esl DB.esl noPK.esl PK.auth noPK.auth KEK.auth DB.auth"
for file in $KEYS; do
if [ -f $file ]; then
echo "Error: keys already exist in $(pwd)" >&2
@@ -50,6 +50,10 @@ sign-efi-sig-list -t "$(date --date='1 second' +'%Y-%m-%d %H:%M:%S')" \
-k PK.key -c PK.crt PK PK.esl PK.auth
sign-efi-sig-list -t "$(date --date='1 second' +'%Y-%m-%d %H:%M:%S')" \
-k PK.key -c PK.crt PK noPK.esl noPK.auth
+sign-efi-sig-list -t "$(date --date='1 second' +'%Y-%m-%d %H:%M:%S')" \
+ -k PK.key -c PK.crt KEK KEK.esl KEK.auth
+sign-efi-sig-list -t "$(date --date='1 second' +'%Y-%m-%d %H:%M:%S')" \
+ -k KEK.key -c KEK.crt DB DB.esl DB.auth
chmod 0600 *.key