summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Vihrov2016-08-19 13:21:37 +0300
committerAndrey Vihrov2016-08-19 13:21:37 +0300
commitaf6749944562667c2008deff1f59110a7eb5bc0b (patch)
treefbd63ddb9c249965498736c36aa94d83dcd12d29
downloadaur-af6749944562667c2008deff1f59110a7eb5bc0b.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..445bc0277c72
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Aug 19 09:38:55 UTC 2016
+pkgbase = sbupdate-git
+ pkgdesc = Generate and sign kernel images for UEFI Secure Boot
+ pkgver = 0.r2.e4b282f
+ pkgrel = 1
+ url = https://github.com/andreyv/sbupdate
+ arch = any
+ license = GPL3
+ depends = systemd
+ depends = binutils
+ depends = sbsigntools
+ backup = etc/default/sbupdate
+ source = git+https://github.com/andreyv/sbupdate.git
+ sha256sums = SKIP
+
+pkgname = sbupdate-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73e6544e32f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Andrey Vihrov <andrey.vihrov at gmail.com>
+
+pkgname=sbupdate-git
+pkgver=0.r6.f742509
+pkgrel=1
+pkgdesc="Generate and sign kernel images for UEFI Secure Boot"
+arch=('any')
+url="https://github.com/andreyv/sbupdate"
+license=('GPL3')
+depends=('systemd' 'binutils' 'sbsigntools')
+backup=('etc/default/sbupdate')
+source=("git+https://github.com/andreyv/sbupdate.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd sbupdate
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd sbupdate
+
+ install -D -m 0755 sbupdate "${pkgdir}/usr/bin/sbupdate"
+ install -D -m 0644 sbupdate.hook "${pkgdir}/usr/share/libalpm/hooks/sbupdate.hook"
+
+ install -D -m 0644 default "${pkgdir}/etc/default/sbupdate"
+
+ install -D -m 0644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+}
+
+# vim:set ts=2 sw=2 et: