summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRhinoceros2023-01-13 10:46:17 +1100
committerRhinoceros2023-01-13 10:46:17 +1100
commit39e0317b7b6e1baa9a252d1c0110f5da80a63799 (patch)
treec63ca17e0ffe60c6a5ee535878017366e44a61a6
parent28fcc3c677d2c1439182e91e7c5ef03642584874 (diff)
downloadaur-39e0317b7b6e1baa9a252d1c0110f5da80a63799.tar.gz
Update to 0.8.3-1
* Upstream changelog: https://github.com/andmarti1424/sc-im/releases/tag/v0.8.3 * Makefile now selects Linux clipboard by default, so no need to patch this part.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--arch.0.8.0.patch32
-rw-r--r--sc-im_arch_0.8.3.patch11
4 files changed, 21 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1127a4f04b73..efd6ccf5bd66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sc-im
pkgdesc = A spreadsheet program based on SC
- pkgver = 0.8.2
+ pkgver = 0.8.3
pkgrel = 1
url = https://github.com/andmarti1424/sc-im
arch = i686
@@ -14,9 +14,9 @@ pkgbase = sc-im
optdepends = gnuplot: create graphs
conflicts = scim-spreadsheet
conflicts = sc-im-git
- source = sc-im-0.8.2.tar.gz::https://github.com/andmarti1424/sc-im/archive/v0.8.2.tar.gz
- source = arch.0.8.0.patch
- sha256sums = 7f00c98601e7f7709431fb4cbb83707c87016a3b015d48e5a7c2f018eff4b7f7
- sha256sums = 191c8537f75decb0bf8d00db9543b07985684bf10308ff63c6648de70b7ff6e5
+ source = sc-im-0.8.3.tar.gz::https://github.com/andmarti1424/sc-im/archive/v0.8.3.tar.gz
+ source = sc-im_arch_0.8.3.patch
+ sha256sums = 5568f9987b6d26535c0e7a427158848f1bc03d829f74e41cbcf007d8704e9bd3
+ sha256sums = 2ba5a7c20d250d14a32dd3fad956779551cc18ab5f080ce149ba8395a70d0c41
pkgname = sc-im
diff --git a/PKGBUILD b/PKGBUILD
index 91777c4d5ecc..50ec1c6c5a32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
pkgname=sc-im
-pkgver=0.8.2
+pkgver=0.8.3
pkgrel=1
pkgdesc='A spreadsheet program based on SC'
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
@@ -13,14 +13,14 @@ optdepends=('libxlsxwriter: export to xlsx. Requires rebuild of sc-im'
license=('BSD')
conflicts=('scim-spreadsheet' 'sc-im-git')
source=("$pkgname-$pkgver.tar.gz::https://github.com/andmarti1424/$pkgname/archive/v${pkgver}.tar.gz"
- 'arch.0.8.0.patch')
-sha256sums=('7f00c98601e7f7709431fb4cbb83707c87016a3b015d48e5a7c2f018eff4b7f7'
- '191c8537f75decb0bf8d00db9543b07985684bf10308ff63c6648de70b7ff6e5')
+ "${pkgname}_arch_0.8.3.patch")
+sha256sums=('5568f9987b6d26535c0e7a427158848f1bc03d829f74e41cbcf007d8704e9bd3'
+ '2ba5a7c20d250d14a32dd3fad956779551cc18ab5f080ce149ba8395a70d0c41')
prepare() {
cd "$pkgname-$pkgver/src"
# install things in the correct place for package managers
- patch <"$srcdir/arch.0.8.0.patch"
+ patch <"$srcdir/${pkgname}_arch_0.8.3.patch"
}
build() {
diff --git a/arch.0.8.0.patch b/arch.0.8.0.patch
deleted file mode 100644
index d87e0aee670c..000000000000
--- a/arch.0.8.0.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- Makefile.orig 2021-03-18 09:17:13.556100711 +1100
-+++ Makefile 2021-03-18 09:15:51.273178297 +1100
-@@ -2,7 +2,7 @@
- name = sc-im
-
- # The base directory where everything should be installed.
--prefix = /usr/local
-+prefix = /usr
-
- EXDIR = $(prefix)/bin
- HELPDIR = $(prefix)/share/$(name)
-@@ -58,16 +58,16 @@
- # Choose one of the following commands for copying to different clipboards:
- # You can later change it at runtime.
- #to copy to tmux clipboard:
--CFLAGS += -DDEFAULT_COPY_TO_CLIPBOARD_CMD=\""tmux load-buffer"\"
-+#CFLAGS += -DDEFAULT_COPY_TO_CLIPBOARD_CMD=\""tmux load-buffer"\"
- #to copy to X clipboard:
--#CFLAGS += -DDEFAULT_COPY_TO_CLIPBOARD_CMD=\""xclip -i -selection clipboard <"\"
-+CFLAGS += -DDEFAULT_COPY_TO_CLIPBOARD_CMD=\""xclip -i -selection clipboard <"\"
- #to copy to OSX clipboard:
- #CFLAGS += -DDEFAULT_COPY_TO_CLIPBOARD_CMD=\""pbcopy <"\"
- #
- # Choose one of the proposed commands for pasting from different clipboards:
- # You can later change it at runtime.
--CFLAGS += -DDEFAULT_PASTE_FROM_CLIPBOARD_CMD=\""tmux show-buffer"\"
--#CFLAGS += -DDEFAULT_PASTE_FROM_CLIPBOARD_CMD=\""xclip -o -selection clipboard"\"
-+#CFLAGS += -DDEFAULT_PASTE_FROM_CLIPBOARD_CMD=\""tmux show-buffer"\"
-+CFLAGS += -DDEFAULT_PASTE_FROM_CLIPBOARD_CMD=\""xclip -o -selection clipboard"\"
- #CFLAGS += -DDEFAULT_PASTE_FROM_CLIPBOARD_CMD=\""pbpaste"\"
-
- # NOTE: libxlsreader (libxls) is required for xls file reading support
diff --git a/sc-im_arch_0.8.3.patch b/sc-im_arch_0.8.3.patch
new file mode 100644
index 000000000000..eb23412f9814
--- /dev/null
+++ b/sc-im_arch_0.8.3.patch
@@ -0,0 +1,11 @@
+--- Makefile.orig 2023-01-13 04:57:03.000000000 +1100
++++ Makefile 2023-01-13 10:32:52.688654814 +1100
+@@ -2,7 +2,7 @@
+ name = sc-im
+
+ # The base directory where everything should be installed.
+-prefix = /usr/local
++prefix = /usr
+
+ EXDIR = $(prefix)/bin
+ HELPDIR = $(prefix)/share/$(name)