summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandr Boiko2016-07-15 18:52:44 +1100
committerAlexandr Boiko2016-07-15 18:52:44 +1100
commitf4ed93729d99bfd9430e8bed3b21aa4a17969806 (patch)
treeff2c638fc44c2fea36ffa860985f8261425aeb68
downloadaur-f4ed93729d99bfd9430e8bed3b21aa4a17969806.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--Makefile.patch25
-rw-r--r--PKGBUILD36
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8af4826eb8e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = sc-tool
+ pkgdesc = Administration tool for Linux-based ISP traffic shaper
+ pkgver = 1.5.7
+ pkgrel = 1
+ url = https://sourceforge.net/projects/sc-tool/files/sc-tool
+ arch = any
+ license = GPL
+ depends = perl
+ source = https://sourceforge.net/projects/sc-tool/files/sc-tool/sc-1.5.7.tar.bz2
+ source = Makefile.patch
+ md5sums = ac9fa4dd38d2893d7eea91368448e7c9
+ md5sums = 853cc12517dca9610fb843c652f613de
+
+pkgname = sc-tool
+
diff --git a/Makefile.patch b/Makefile.patch
new file mode 100644
index 000000000000..4ef57490ee71
--- /dev/null
+++ b/Makefile.patch
@@ -0,0 +1,25 @@
+--- Makefile 2016-07-15 18:44:15.481315032 +1100
++++ Makefile.new 2016-07-15 18:42:14.297637526 +1100
+@@ -3,10 +3,10 @@
+ ARCH=$(PROG)-$(VERSION).tar.bz2
+ SERVICE=$(PROG)
+
+-PREFIX?=/usr/local
+-SBINDIR?=$(PREFIX)/sbin
++PREFIX?=/usr
++SBINDIR?=$(PREFIX)/bin
+ MANDIR?=$(PREFIX)/share/man
+-INITDIR?=/etc/init.d
++INITDIR?=/usr/lib/systemd/scripts
+ CONFDIR?=/etc/$(PROG)
+
+ CLFILES?=$(PROG).8 $(PROG).conf.5 $(ARCH) *.batch
+@@ -31,7 +31,7 @@
+ echo " uninstall uninstall program"
+
+ install: $(PROG) $(PROG).init $(PROG).conf.5 $(PROG).8 $(PROG).conf
+- install -D -m 755 $(PROG) $(DESTDIR)$(SBINDIR)
++ install -D -m 755 $(PROG) $(DESTDIR)$(SBINDIR)/$(PROG)
+ install -D -m 644 $(PROG).8 $(DESTDIR)$(MANDIR)/man8/$(PROG).8
+ install -D -m 644 $(PROG).conf.5 $(DESTDIR)$(MANDIR)/man5/$(PROG).conf.5
+ install -D -m 755 $(PROG).init $(DESTDIR)$(INITDIR)/$(SERVICE)
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2bca14b974ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Aleksandr Boiko <brdcom@ya.ru>
+pkgname=sc-tool
+_pkgname=sc
+pkgver=1.5.7
+pkgrel=1
+epoch=
+pkgdesc="Administration tool for Linux-based ISP traffic shaper"
+arch=('any')
+url="https://sourceforge.net/projects/sc-tool/files/sc-tool"
+license=('GPL')
+depends=('perl')
+install=
+source=("$url/$_pkgname-$pkgver.tar.bz2"
+ 'Makefile.patch')
+md5sums=('ac9fa4dd38d2893d7eea91368448e7c9'
+ '853cc12517dca9610fb843c652f613de')
+
+prepare() {
+ cd "$_pkgname-$pkgver"
+ msg2 "Patching Makefile ..."
+ patch -p0 -i ../Makefile.patch
+}
+
+build() {
+ cd "$_pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ install -Dm0644 README "$pkgdir/usr/share/doc/$pkgname/README"
+}
+
+md5sums=('ac9fa4dd38d2893d7eea91368448e7c9'
+ '853cc12517dca9610fb843c652f613de')