summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikael Blomstrand2019-11-01 12:38:48 +0100
committerMikael Blomstrand2019-11-01 12:38:48 +0100
commitccd0c5514fad2c9f684ce9ba12ac29c880de435a (patch)
tree135019af9ce48ac17c77dc357a451cc8c2525490
parentaf810bc1055bc4d1f088a4df703ae0ae946c8408 (diff)
downloadaur-ccd0c5514fad2c9f684ce9ba12ac29c880de435a.tar.gz
Update to 0.20.0-RC1
Start using RC versions instead. I decided to remove the hyphen instead of replaceing it, because vercmp gives 0.20.0_RC1 > 0.20.0 > 0.20.0RC1.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eaccea35be8f..cf44ef8bf216 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = scala-dotty
pkgdesc = Research compiler that will become Scala 3
- pkgver = 0.18.1
+ pkgver = 0.20.0RC1
pkgrel = 1
url = http://dotty.epfl.ch
arch = any
license = BSD
depends = java-environment>=8
depends = java-environment<=11
- source = https://github.com/lampepfl/dotty/releases/download/0.18.1/dotty-0.18.1.tar.gz
- sha1sums = e2d6138f087327a7d82416d183ec52640fc61e55
- sha256sums = a9e102d8289b6367e737a523691f6ecfe01e1834719f8682f7f1d4cc3c33efed
+ source = https://github.com/lampepfl/dotty/releases/download/0.20.0-RC1/dotty-0.20.0-RC1.tar.gz
+ sha1sums = 52f2014cd57b539a821b73abc6a1a1011c1ce35d
+ sha256sums = 86a6d62614e250dacd9b46d32e2b5765a45956502a73f64c28062e26461d1a23
pkgname = scala-dotty
diff --git a/PKGBUILD b/PKGBUILD
index 359e6c19eae5..bb07ab2abec4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,22 @@
# Contributor: Jendrik Wenke <jendrikwenke+aur at gmail dot com>
pkgname=scala-dotty
-pkgver=0.18.1
+_reltag=0.20.0-RC1
+pkgver=${_reltag//-/}
pkgrel=1
pkgdesc='Research compiler that will become Scala 3'
arch=('any')
url='http://dotty.epfl.ch'
license=('BSD')
depends=('java-environment>=8' 'java-environment<=11')
-source=("https://github.com/lampepfl/dotty/releases/download/${pkgver}/dotty-${pkgver}.tar.gz")
-sha1sums=('e2d6138f087327a7d82416d183ec52640fc61e55')
-sha256sums=('a9e102d8289b6367e737a523691f6ecfe01e1834719f8682f7f1d4cc3c33efed')
+source=("https://github.com/lampepfl/dotty/releases/download/${_reltag}/dotty-${_reltag}.tar.gz")
+sha1sums=('52f2014cd57b539a821b73abc6a1a1011c1ce35d')
+sha256sums=('86a6d62614e250dacd9b46d32e2b5765a45956502a73f64c28062e26461d1a23')
package() {
install -d "${pkgdir}/usr/bin" "${pkgdir}/usr/share/scala-dotty/bin"
- cp -r "${srcdir}/dotty-${pkgver}/lib" "${pkgdir}/usr/share/scala-dotty"
- install -m755 "${srcdir}/dotty-${pkgver}/bin/"* "${pkgdir}/usr/share/scala-dotty/bin"
+ cp -r "${srcdir}/dotty-${_reltag}/lib" "${pkgdir}/usr/share/scala-dotty"
+ install -m755 "${srcdir}/dotty-${_reltag}/bin/"* "${pkgdir}/usr/share/scala-dotty/bin"
ln -s "../share/scala-dotty/bin/dotc" "${pkgdir}/usr/bin/dotc"
ln -s "../share/scala-dotty/bin/dotd" "${pkgdir}/usr/bin/dotd"
ln -s "../share/scala-dotty/bin/dotr" "${pkgdir}/usr/bin/dotr"