summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVasili Novikov2020-09-15 09:13:28 +0200
committerVasili Novikov2020-09-15 09:13:28 +0200
commit407f90fa71171233d45e566f8a178741135cc40a (patch)
tree35670b2ad9cce945d5fb2669598f496cc15273b1
parent3c11f294c08044265a2b0797f9a0a5ad20491353 (diff)
downloadaur-407f90fa71171233d45e566f8a178741135cc40a.tar.gz
Update to use new scalafmt-s CI
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD16
3 files changed, 19 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 419a67cf3fc7..84dea8f3df1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = scalafmt-native-bin
- pkgdesc = Code formatter for Scala, native version via graalvm
- pkgver = 2.6.3
+ pkgdesc = Code formatter for Scala, native version via graalvm, statically compiled with musl
+ pkgver = 2.7.1
pkgrel = 1
url = https://scalameta.org/scalafmt/
- arch = any
+ arch = x86_64
license = Apache-2.0
- source = scalafmt-native-bin-2.6.3.zip::https://github.com/scalameta/scalafmt/releases/download/v2.6.3/scalafmt-linux.zip
- sha256sums = c4d42bfddea3a65a3099ba1f9787af5f9995633512750d661d51b737b6ebdf30
+ source = scalafmt-native-bin-2.7.1.musl::https://github.com/scalameta/scalafmt/releases/download/v2.7.1/scalafmt-linux-musl
+ sha256sums = 6fb4301d5aece59fb11dbc7e8a57551952398ddef1591544d4c4857471d61edf
pkgname = scalafmt-native-bin
diff --git a/.gitignore b/.gitignore
index 0d57630493ff..1b52f65ab69f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,9 @@
/pkg/
/src/
-/*.pkg.tar.xz
-/*.zip
+#### built package
+/*.pkg.tar*
+
+#### downloaded binary
+/scalafmt-*.musl
+
diff --git a/PKGBUILD b/PKGBUILD
index c80cecbe4f43..80cca9f4cfe5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Vasili Novikov <n1dr+cmarchlinux@yaaandex.com> (replace "aaa" with "a")
+
pkgname=scalafmt-native-bin
-pkgver=2.6.3
+pkgver=2.7.1
pkgrel=1
-pkgdesc='Code formatter for Scala, native version via graalvm'
+pkgdesc='Code formatter for Scala, native version via graalvm, statically compiled with musl'
url='https://scalameta.org/scalafmt/'
-source=("${pkgname}-${pkgver}.zip::https://github.com/scalameta/scalafmt/releases/download/v$pkgver/scalafmt-linux.zip")
+source=("${pkgname}-${pkgver}.musl::https://github.com/scalameta/scalafmt/releases/download/v${pkgver}/scalafmt-linux-musl")
+
license=('Apache-2.0')
-# I'm not actually sure which architectures are supported.
-# Please write if the binary won't work.
-arch=('any')
+arch=('x86_64')
-sha256sums=('c4d42bfddea3a65a3099ba1f9787af5f9995633512750d661d51b737b6ebdf30')
+sha256sums=('6fb4301d5aece59fb11dbc7e8a57551952398ddef1591544d4c4857471d61edf')
package() {
cd "$srcdir"
- install -Dm755 scalafmt "${pkgdir}/usr/bin/scalafmt"
+ install -Dm755 "${pkgname}-${pkgver}.musl" "${pkgdir}/usr/bin/scalafmt"
}