summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Garcia2017-05-16 13:16:09 -0500
committerTony Garcia2017-05-16 13:16:09 -0500
commit5298f7394e3876551f388762bfe2ab04c7766733 (patch)
tree8d8c434484ba7921dffbb61eb827aa9d1a703145
downloadaur-5298f7394e3876551f388762bfe2ab04c7766733.tar.gz
Initial commit, version 1.25.3
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e25b62a5c1f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = scaleft-client-tools
+ pkgdesc = ScaleFT client tools
+ pkgver = 1.25.3
+ pkgrel = 1
+ url = https://scaleft.com
+ arch = x86_64
+ license = custom
+ makedepends = rpmextract
+ depends = glibc
+ source = https://pkg.scaleft.com/rpm/scaleft-client-tools-1.25.3-1.x86_64.rpm
+ sha256sums = 1cefc915e29218e1f6629b519e64d56e00c01e49a48c4e5514f5f9450c3dfe14
+
+pkgname = scaleft-client-tools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5bfd88f80080
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Tony G. <aur at tonyskapunk dot net>
+
+pkgname='scaleft-client-tools'
+pkgdesc='ScaleFT client tools'
+pkgver=1.25.3
+pkgrel=1
+arch=('x86_64')
+url="https://scaleft.com"
+license=('custom')
+makedepends=('rpmextract')
+depends=('glibc')
+source=("https://pkg.scaleft.com/rpm/${pkgname}-${pkgver}-${pkgrel}.${arch}.rpm")
+sha256sums=('1cefc915e29218e1f6629b519e64d56e00c01e49a48c4e5514f5f9450c3dfe14')
+
+prepare() {
+ rpmextract.sh ${pkgname}-${pkgver}-${pkgrel}.${arch}.rpm
+}
+
+package() {
+ install -Dm0755 usr/bin/sft ${pkgdir}/usr/bin/sft
+ install -Dm0644 usr/share/doc/scaleft-client-tools/LICENSE.txt \
+ ${pkgdir}/share/doc/scaleft-client-tools/LICENSE.txt
+}
+
+# deb: curl -s https://pkg.scaleft.com/deb/pool/linux/main/s/scaleft-client-tools/ | grep -Po 'scale[\w-\d.]*' | sort -V | tail -1
+# rpm: curl -s https://pkg.scaleft.com/rpm/ | grep -Po 'scaleft-client-tools[\w-\d.]*' | sort -V | tail -1