summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122015-08-09 09:27:20 +0200
committerwillemw122015-08-09 09:27:20 +0200
commit9a43e47f621a8afdcc27a7d50e119a4fdc93f663 (patch)
tree964173628da32216f2b97379d419beb9816371a7
downloadaur-9a43e47f621a8afdcc27a7d50e119a4fdc93f663.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD43
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..70f0e2eafd48
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = scalpel-git
+ pkgdesc = A frugal, high performance file carver
+ pkgver = r24.47815c2
+ pkgrel = 1
+ url = https://github.com/sleuthkit/scalpel
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ depends = tre
+ provides = scalpel
+ conflicts = scalpel
+ source = scalpel-git::git+https://github.com/sleuthkit/scalpel
+ md5sums = SKIP
+
+pkgname = scalpel-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd04a1c6e39a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: willemw <willemw12@gmail.com>
+# Contributor: Meta Mantra <m3tamantra at gmail dot com>
+# Contributor: DrZaius <lou at fakeoutdoorsman dot com>
+# Contributor: Adam Wolk <netprobe at gmail dot com>
+
+_pkgname=scalpel
+pkgname=$_pkgname-git
+pkgver=r24.47815c2
+pkgrel=1
+pkgdesc="A frugal, high performance file carver"
+arch=('i686' 'x86_64')
+url="https://github.com/sleuthkit/scalpel"
+license=('Apache')
+depends=('tre')
+makedepends=('git')
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=($pkgname::git+https://github.com/sleuthkit/scalpel)
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd $pkgname
+ sed -i 's|#define[ \t]*SCALPEL_DEFAULT_CONFIG_FILE[ \t]*"scalpel.conf"|#define SCALPEL_DEFAULT_CONFIG_FILE "/etc/scalpel/scalpel.conf"|' src/scalpel.h
+}
+
+build() {
+ cd $pkgname
+ ./bootstrap
+ ./configure --with-pic --prefix=/usr
+ make
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir" install
+ install -Dm644 scalpel.conf "$pkgdir/etc/scalpel/scalpel.conf"
+}
+