summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2015-07-17 02:02:52 +0200
committeranthraxx2015-07-17 02:02:52 +0200
commit42593a601c9a4e624e677c6480352309583193f2 (patch)
tree1d32c9adef59df53681ff134eef63e552f1ea97b
parent63f103e330158a72843a5a74def6a95d193e6a1c (diff)
downloadaur-42593a601c9a4e624e677c6480352309583193f2.tar.gz
upgpkg: scanmem-git 0.15.2.6.g5cf1f26-1
upstream release
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD41
-rw-r--r--scanmem.install23
3 files changed, 48 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0604d51a021c..c3fe3ce5d95a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = scanmem-git
- pkgdesc = A utility used to locate the address of a variable in an executing process.
- pkgver = v0.15.2
+ pkgdesc = Memory scanner designed to isolate the address of an arbitrary variable in an executing process
+ pkgver = 0.15.2.6.g5cf1f26
pkgrel = 1
- url = https://github.com/coolwan/scanmem
+ url = https://github.com/scanmem/scanmem
+ install = scanmem.install
arch = i686
arch = x86_64
license = GPL3
+ makedepends = git
makedepends = intltool
- depends = python
depends = pygtk
- depends = polkit
depends = python-gobject
+ depends = polkit
provides = scanmem
conflicts = scanmem
- source = git+https://github.com/scanmem/scanmem.git
- md5sums = SKIP
+ source = scanmem-git::git+https://github.com/scanmem/scanmem.git
+ sha512sums = SKIP
pkgname = scanmem-git
diff --git a/PKGBUILD b/PKGBUILD
index 50e9407f7d31..e11d4cc39ddc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,36 @@
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
# Contributor: Allen Choong <allencch at hotmail dot com>
pkgname=scanmem-git
-_gitname=scanmem
-pkgver=v0.15.2
+pkgver=0.15.2.6.g5cf1f26
pkgrel=1
-pkgdesc="A utility used to locate the address of a variable in an executing process."
+pkgdesc="Memory scanner designed to isolate the address of an arbitrary variable in an executing process"
+url="https://github.com/scanmem/scanmem"
arch=('i686' 'x86_64')
-url="https://github.com/coolwan/scanmem"
+license=('GPL3')
provides=('scanmem')
conflicts=('scanmem')
-license=('GPL3')
-depends=('python' 'pygtk' 'polkit' 'python-gobject')
-makedepends=('intltool')
-#optdepends=('gksu: needed for the GameConqueror GUI.')
-source=("git+https://github.com/scanmem/scanmem.git")
-md5sums=('SKIP')
+depends=('pygtk' 'python-gobject' 'polkit')
+makedepends=('git' 'intltool')
+install=scanmem.install
+source=(${pkgname}::git+https://github.com/scanmem/scanmem.git)
+sha512sums=('SKIP')
pkgver() {
- cd $_gitname
- # Use the tag of the last commit
- git describe --always | sed 's|-|.|g'
+ cd ${pkgname}
+ git describe --always|sed 's|-|.|g'|sed -r 's|v(.*)|\1|'
}
build() {
- cd $_gitname
-
+ cd ${pkgname}
./autogen.sh
./configure --enable-gui --prefix=/usr
- msg2 "Building..."
- make -s
+ make
}
package() {
- cd $_gitname
- make -s DESTDIR="$pkgdir" install
-
- # Replacing calls to the Python 3.x interpreter to the Python 2.x one:
- #sed 's|python|python2|g' -i "$pkgdir/usr/bin/gameconqueror"
- #sed 's|#!/usr/bin/env python|#!/usr/bin/env python2|g' -i \
- # "$pkgdir/usr/share/gameconqueror/"{backend.py,GameConqueror.py,hexview.py}
+ cd ${pkgname}
+ make DESTDIR="${pkgdir}" install
}
+# vim: ts=2 sw=2 et:
diff --git a/scanmem.install b/scanmem.install
new file mode 100644
index 000000000000..dad6017120c9
--- /dev/null
+++ b/scanmem.install
@@ -0,0 +1,23 @@
+update_cache() {
+ if [ -x usr/bin/xdg-icon-resource ]; then
+ xdg-icon-resource forceupdate --theme hicolor > /dev/null 2>&1
+ fi
+
+ if [ -x usr/bin/update-desktop-database ]; then
+ usr/bin/update-desktop-database -q
+ fi
+}
+
+post_install() {
+ update_cache
+}
+
+post_upgrade() {
+ update_cache
+}
+
+post_remove() {
+ update_cache
+}
+
+# vim: ts=2 sw=2 et: