summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2022-07-07 12:20:34 +0200
committerPhilipp A2022-07-07 12:20:34 +0200
commit46549b52e414ed2e6d45b1c0dfdb9be37ca26c2d (patch)
treefdeb73d6eb2891a59e0290dcdb06ea272c1ee6dd
parent8d564bc4b107fd9ff51865786136622931aa0693 (diff)
downloadaur-46549b52e414ed2e6d45b1c0dfdb9be37ca26c2d.tar.gz
v1.9.1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD14
2 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9325ce332198..f957a74394cf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = scanpy
pkgdesc = Single-Cell Analysis in Python
- pkgver = 1.8.2
- pkgrel = 2
+ pkgver = 1.9.1
+ pkgrel = 1
url = https://github.com/theislab/scanpy
arch = any
license = BSD
makedepends = python-build
makedepends = python-installer
+ makedepends = python-flit-core
+ makedepends = python-setuptools-scm
depends = python-anndata>=0.7.4
depends = python-numpy>=1.17.0
- depends = python-matplotlib>=3.1.2
- depends = python-pandas>=0.21
+ depends = python-matplotlib>=3.4
+ depends = python-pandas>=1.0
depends = python-scipy>=1.4
depends = python-seaborn
depends = python-h5py
- depends = python-pytables
depends = python-tqdm
depends = python-scikit-learn>=0.21.2
depends = python-statsmodels>=0.10.0
@@ -37,7 +38,7 @@ pkgbase = scanpy
optdepends = python-scrublet: Cell doublet detection
provides = scanpy
provides = python-scanpy
- source = https://files.pythonhosted.org/packages/source/s/scanpy/scanpy-1.8.2.tar.gz
- sha256sums = 0c0baa6f08cec50b89b512cef3bfc7f612b215ce02c0fb49cc01c2acfbb2e9bb
+ source = https://files.pythonhosted.org/packages/source/s/scanpy/scanpy-1.9.1.tar.gz
+ sha256sums = 00c9a83b649da7e0171c91e9a08cff632102faa760614fd05cd4d1dbba4eb541
pkgname = scanpy
diff --git a/PKGBUILD b/PKGBUILD
index 19a37411fc3e..2c206320c9fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Philipp A. <flying-sheep@web.de>
pkgname=scanpy
-pkgver=1.8.2
-pkgrel=2
+pkgver=1.9.1
+pkgrel=1
pkgdesc='Single-Cell Analysis in Python'
arch=(any)
provides=(scanpy python-scanpy)
@@ -11,12 +11,11 @@ license=(BSD)
depends=(
'python-anndata>=0.7.4'
'python-numpy>=1.17.0'
- 'python-matplotlib>=3.1.2'
- 'python-pandas>=0.21'
+ 'python-matplotlib>=3.4'
+ 'python-pandas>=1.0'
'python-scipy>=1.4'
python-seaborn
python-h5py
- python-pytables
python-tqdm
'python-scikit-learn>=0.21.2'
'python-statsmodels>=0.10.0'
@@ -40,12 +39,13 @@ optdepends=(
'python-scanorama: Scanorama dataset integration algorithm'
'python-scrublet: Cell doublet detection'
)
-makedepends=(python-build python-installer)
+makedepends=(python-build python-installer python-flit-core python-setuptools-scm)
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
-sha256sums=('0c0baa6f08cec50b89b512cef3bfc7f612b215ce02c0fb49cc01c2acfbb2e9bb')
+sha256sums=('00c9a83b649da7e0171c91e9a08cff632102faa760614fd05cd4d1dbba4eb541')
build() {
cd "$pkgname-$pkgver"
+ # no idea why the dep check doesn’t work …
python -m build --wheel --no-isolation --skip-dependency-check
}