summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2019-04-16 15:16:29 +0200
committerPhilipp A2019-04-16 15:16:29 +0200
commit16aaf588ec8ff0684080adcadfeda8414d462980 (patch)
tree2c9af395ac971715516f83ff293c5ee9e747e47d
downloadaur-16aaf588ec8ff0684080adcadfeda8414d462980.tar.gz
init
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD24
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a6c58e396982
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = scanpy-scripts
+ pkgdesc = Scripts for using scanpy from the command line
+ pkgver = 0.1.0.1
+ pkgrel = 1
+ url = https://github.com/ebi-gene-expression-group/scanpy-scripts
+ arch = any
+ license = MIT
+ makedepends = install-wheel-scripts
+ depends = scanpy
+ depends = python-louvain-igraph
+ provides = scanpy
+ provides = python-scanpy
+ noextract = scanpy_scripts-0.1.0.1-py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py3/s/scanpy-scripts/scanpy_scripts-0.1.0.1-py3-none-any.whl
+ sha256sums = a46e5cc76f40b0ce281d982a75d3c0030e276bb1645b931e5fc3e5cbde5625e5
+
+pkgname = scanpy-scripts
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cb3cc40a81f9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src/
+/pkg/
+/*.pkg.tar.xz
+/*.whl
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..34c5c1e5c0b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Philipp A. <flying-sheep@web.de>
+
+pkgname=scanpy-scripts
+pkgver=0.1.0.1
+pkgrel=1
+pkgdesc='Scripts for using scanpy from the command line'
+arch=(any)
+provides=(scanpy python-scanpy)
+url='https://github.com/ebi-gene-expression-group/scanpy-scripts'
+license=(MIT)
+depends=(scanpy python-louvain-igraph)
+makedepends=(install-wheel-scripts)
+_pyarch=py3
+_wheel="${pkgname/-/_}-$pkgver-$_pyarch-none-any.whl"
+source=("https://files.pythonhosted.org/packages/$_pyarch/${pkgname::1}/$pkgname/$_wheel")
+sha256sums=('a46e5cc76f40b0ce281d982a75d3c0030e276bb1645b931e5fc3e5cbde5625e5')
+noextract=("$_wheel")
+
+package() {
+ local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ mkdir -p "$site"
+ unzip "$_wheel" -d "$site"
+ install-wheel-scripts --prefix="$pkgdir/usr" "$_wheel"
+}