summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-06-21 18:19:09 +0300
committerDimitris Kiziridis2020-06-21 18:19:09 +0300
commitceb08b0d07a8eb2781cdf576f1c523b18ad05332 (patch)
tree5af509f25536efc4405b4d7889dbdd37fbc38e1c
downloadaur-scanrepo-bin.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9bc8119b6933
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = scanrepo-bin
+ pkgdesc = CLI tool that finds secrets accidentally committed to a git repo, eg passwords, private keys
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://github.com/UKHomeOffice/repo-security-scanner
+ arch = x86_64
+ license = MIT
+ provides = scanrepo
+ source = scanrepo-bin-0.4.0.tar.gz::https://github.com/UKHomeOffice/repo-security-scanner/releases/download/0.4.0/scanrepo-0.4.0-linux-amd64.tar.gz
+ source = LICENSE::https://github.com/UKHomeOffice/repo-security-scanner/raw/master/LICENSE
+ sha256sums = 149d374920816c9bafa5289ab0f7e6d6ee4c4495bb7f1cdb3c05ffe7945674cd
+ sha256sums = 9789a1f817c2a2b83f2d990c30896a9016bd2d38424edb7a60077654becf26d0
+
+pkgname = scanrepo-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bee8f4d86bfb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=scanrepo-bin
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="CLI tool that finds secrets accidentally committed to a git repo, eg passwords, private keys"
+arch=('x86_64')
+url='https://github.com/UKHomeOffice/repo-security-scanner'
+license=('MIT')
+provides=('scanrepo')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/UKHomeOffice/repo-security-scanner/releases/download/${pkgver}/scanrepo-${pkgver}-linux-amd64.tar.gz"
+ 'LICENSE::https://github.com/UKHomeOffice/repo-security-scanner/raw/master/LICENSE')
+sha256sums=('149d374920816c9bafa5289ab0f7e6d6ee4c4495bb7f1cdb3c05ffe7945674cd'
+ '9789a1f817c2a2b83f2d990c30896a9016bd2d38424edb7a60077654becf26d0')
+
+package() {
+ install -Dm755 scanrepo "${pkgdir}/usr/bin/scanrepo"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+} \ No newline at end of file