summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Hasoň2021-01-02 16:53:59 +0100
committerMartin Hasoň2021-01-02 16:53:59 +0100
commit4f1feffac521dede2cceea8e4e59b2a347964454 (patch)
treef7f9621b7e5868e7c699d7fd9188e44d482c0336
parent11814715aae249d22266c9dfa25dbf36acc2751b (diff)
downloadaur-4f1feffac521dede2cceea8e4e59b2a347964454.tar.gz
Add patch for Qt 5.15
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
-rw-r--r--package.patch67
3 files changed, 80 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0e1a2818444..a7a216951dee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = scantailor-advanced
pkgdesc = An interactive post-processing tool for scanned pages.
pkgver = 1.0.16
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/4lex4/scantailor-advanced
arch = x86_64
license = GPL3
@@ -14,8 +14,11 @@ pkgbase = scantailor-advanced
depends = libpng>=1.0.0
depends = zlib>=1.0.0
depends = libtiff>=4.0.0
+ conflicts = scantailor
source = scantailor-advanced-1.0.16::https://github.com/4lex4/scantailor-advanced/archive/v1.0.16.tar.gz
+ source = package.patch
sha256sums = 84629d2edba4c36c62bdb75eedb145262b894d950bcb95cec0dab43e21bdb909
+ sha256sums = 15680699fd419af8ac624fa01d70dabe52b37dc1b0a94d80b91082c61f0d6634
pkgname = scantailor-advanced
diff --git a/PKGBUILD b/PKGBUILD
index 0995f7015b8f..dd8a0dc1437e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,21 @@
pkgname=scantailor-advanced
pkgver=1.0.16
-pkgrel=1
+pkgrel=2
pkgdesc="An interactive post-processing tool for scanned pages."
arch=("x86_64")
url="https://github.com/4lex4/scantailor-advanced"
license=("GPL3")
depends=("qt5-base" "hicolor-icon-theme" "boost-libs>=1.0.0" "libpng>=1.0.0" "zlib>=1.0.0" "libtiff>=4.0.0")
makedepends=("cmake>=3.9.0" "qt5-tools" "boost>=1.0.0")
-source=("$pkgname-$pkgver::https://github.com/4lex4/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=("84629d2edba4c36c62bdb75eedb145262b894d950bcb95cec0dab43e21bdb909")
+conflicts=("scantailor")
+source=("$pkgname-$pkgver::https://github.com/4lex4/$pkgname/archive/v$pkgver.tar.gz" "package.patch")
+sha256sums=("84629d2edba4c36c62bdb75eedb145262b894d950bcb95cec0dab43e21bdb909" "15680699fd419af8ac624fa01d70dabe52b37dc1b0a94d80b91082c61f0d6634")
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch --forward --strip=1 --input="${srcdir}/package.patch"
+}
build() {
cd "$pkgname-$pkgver"
diff --git a/package.patch b/package.patch
new file mode 100644
index 000000000000..d7e850d5f8fd
--- /dev/null
+++ b/package.patch
@@ -0,0 +1,67 @@
+diff --unified --recursive --text scantailor-advanced-1.0.16/filters/output/OutputGenerator.cpp scantailor-advanced-1.0.16/filters/output/OutputGenerator.cpp
+--- scantailor-advanced-1.0.16/filters/output/OutputGenerator.cpp 2018-07-17 04:04:23.000000000 +0200
++++ scantailor-advanced-1.0.16/filters/output/OutputGenerator.cpp 2021-01-02 16:18:50.911568918 +0100
+@@ -25,6 +25,7 @@
+ #include <imageproc/ImageCombination.h>
+ #include <QDebug>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QtCore/QSettings>
+ #include <boost/bind.hpp>
+ #include "DebugImages.h"
+diff --unified --recursive --text src/scantailor-advanced-1.0.16/filters/page_layout/ImageView.cpp scantailor-advanced-1.0.16/filters/page_layout/ImageView.cpp
+--- scantailor-advanced-1.0.16/filters/page_layout/ImageView.cpp 2018-07-17 04:04:23.000000000 +0200
++++ scantailor-advanced-1.0.16/filters/page_layout/ImageView.cpp 2021-01-02 16:19:10.674838837 +0100
+@@ -27,6 +27,7 @@
+ #include <imageproc/Transform.h>
+ #include <QMouseEvent>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <boost/bind.hpp>
+ #include <boost/lambda/lambda.hpp>
+ #include "ImagePresentation.h"
+diff --unified --recursive --text scantailor-advanced-1.0.16/filters/select_content/ContentBoxFinder.cpp scantailor-advanced-1.0.16/filters/select_content/ContentBoxFinder.cpp
+--- scantailor-advanced-1.0.16/filters/select_content/ContentBoxFinder.cpp 2018-07-17 04:04:23.000000000 +0200
++++ scantailor-advanced-1.0.16/filters/select_content/ContentBoxFinder.cpp 2021-01-02 16:19:30.304741496 +0100
+@@ -19,6 +19,7 @@
+ #include "ContentBoxFinder.h"
+ #include <QDebug>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <cmath>
+ #include <queue>
+ #include "DebugImages.h"
+diff --unified --recursive --text scantailor-advanced-1.0.16/ImageViewBase.cpp scantailor-advanced-1.0.16/ImageViewBase.cpp
+--- scantailor-advanced-1.0.16/ImageViewBase.cpp 2018-07-17 04:04:23.000000000 +0200
++++ scantailor-advanced-1.0.16/ImageViewBase.cpp 2021-01-02 16:17:56.541540662 +0100
+@@ -21,6 +21,8 @@
+ #include <QGLWidget>
+ #include <QMouseEvent>
+ #include <QPaintEngine>
++#include <QPainter>
++#include <QPainterPath>
+ #include <QPointer>
+ #include <QScrollBar>
+ #include <QSettings>
+diff --unified --recursive --text scantailor-advanced-1.0.16/zones/ZoneContextMenuInteraction.cpp scantailor-advanced-1.0.16/zones/ZoneContextMenuInteraction.cpp
+--- scantailor-advanced-1.0.16/zones/ZoneContextMenuInteraction.cpp 2018-07-17 04:04:23.000000000 +0200
++++ scantailor-advanced-1.0.16/zones/ZoneContextMenuInteraction.cpp 2021-01-02 16:20:00.591196620 +0100
+@@ -21,6 +21,7 @@
+ #include <QMenu>
+ #include <QMessageBox>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QSignalMapper>
+ #include <boost/bind.hpp>
+ #include "ImageViewBase.h"
+diff --unified --recursive --text scantailor-advanced-1.0.16/zones/ZoneDefaultInteraction.cpp scantailor-advanced-1.0.16/zones/ZoneDefaultInteraction.cpp
+--- scantailor-advanced-1.0.16/zones/ZoneDefaultInteraction.cpp 2018-07-17 04:04:23.000000000 +0200
++++ scantailor-advanced-1.0.16/zones/ZoneDefaultInteraction.cpp 2021-01-02 16:38:15.740296794 +0100
+@@ -19,6 +19,7 @@
+ #include "ZoneDefaultInteraction.h"
+ #include <QMouseEvent>
+ #include <QPainter>
++#include <QPainterPath>
+ #include "ImageViewBase.h"
+ #include "SerializableSpline.h"
+ #include "ZoneInteractionContext.h"