summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoman Vasilev2020-05-05 21:17:42 +0300
committerRoman Vasilev2020-05-05 21:17:42 +0300
commit14a50a4f670b9159dd531f25426c0e3a61f58c84 (patch)
treebeb74388cfdab283e5053bc88c5d885fcd270b37
downloadaur-14a50a4f670b9159dd531f25426c0e3a61f58c84.tar.gz
Initial Release
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc4a3776e8c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = scantailor-advanced-bin
+ pkgdesc = Interactive post-processing tool for scanned pages that merges the features of the ScanTailor Featured and ScanTailor Enhanced versions, brings new ones and fixes.
+ pkgver = v1.0.16.r119
+ pkgrel = 1
+ url = https://github.com/4lex4/scantailor-advanced
+ arch = x86_64
+ license = GPL3
+ depends = boost-libs
+ depends = libjpeg
+ depends = libpng
+ depends = libtiff
+ depends = qt5-base
+ depends = zlib
+ provides = scantailor-advanced
+ conflicts = scantailor-advanced-git
+ source = https://f002.backblazeb2.com/file/AUR-Store/scantailor-advanced-bin/scantailor-advanced-git-v1.0.16.r119.x86_64.tar.xz
+ sha256sums = 1d8590cc2a35b13260d378bcb87fe136d00d2425ad2a945d2200a02d7328206b
+
+pkgname = scantailor-advanced-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d8ef43782a19
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tar.xz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4862167d909c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=scantailor-advanced-bin
+pkgver=v1.0.16.r119
+pkgrel=1
+pkgdesc="Interactive post-processing tool for scanned pages that merges the features of the ScanTailor Featured and ScanTailor Enhanced versions, brings new ones and fixes. "
+arch=("x86_64")
+url="https://github.com/4lex4/scantailor-advanced"
+license=("GPL3")
+depends=(
+ "boost-libs"
+ "libjpeg"
+ "libpng"
+ "libtiff"
+ "qt5-base"
+ "zlib"
+ )
+makedepends=()
+provides=("scantailor-advanced")
+conflicts=("scantailor-advanced-git")
+source=("https://f002.backblazeb2.com/file/AUR-Store/$pkgname/scantailor-advanced-git-$pkgver.x86_64.tar.xz")
+sha256sums=('1d8590cc2a35b13260d378bcb87fe136d00d2425ad2a945d2200a02d7328206b')
+
+package() {
+ cd $srcdir
+ cp -dpr --no-preserve=ownership usr/ "$pkgdir/usr/"
+}