summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Bachmann2021-12-11 18:09:47 +0100
committerTobias Bachmann2021-12-11 18:09:47 +0100
commit008d7ffe0dbcfd776fdd8f2dd91dd6741c7571ff (patch)
tree7e16fa588375a6ed62f5f029eb5b839082fc94fe
parentbf1177278b7196a180b6c28b471462e39f759147 (diff)
downloadaur-008d7ffe0dbcfd776fdd8f2dd91dd6741c7571ff.tar.gz
Version bump
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD9
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd1077ee258d..01a1f9fbff15 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = scantools
pkgdesc = scantools is a library and a matching set of command line applications for graphics manipulation, written with a view towards the handling of scanned documents and generation of high-quality PDF files.
- pkgver = 1.0.2
+ pkgver = 1.0.5
pkgrel = 1
- url = https://cplx.vm.uni-freiburg.de/scantools/
+ url = https://kebekus.gitlab.io/scantools/
arch = x86_64
license = GPL
makedepends = cmake
@@ -21,8 +21,9 @@ pkgbase = scantools
depends = qt5-base
depends = zlib
depends = poppler-qt5
- source = https://gitlab.com/kebekus/scantools/-/archive/1.0.2/scantools-1.0.2.tar.gz
- sha256sums = 7621e22dee47bf22b260b31cd55aa4bad94bcbdd4ac75e0ede5aca5756de5b64
+ depends = zopfli
+ optdepends = jbig2enc-git: Encode PDF files with JBIG2 (recommended)
+ source = https://gitlab.com/kebekus/scantools/-/archive/1.0.5/scantools-1.0.5.tar.gz
+ sha256sums = 556d76ab71b34ebfa44f216b12b409715c7f94e9e14f04205836d662ea36ad0a
pkgname = scantools
-
diff --git a/PKGBUILD b/PKGBUILD
index 549f4ff252df..35d2744d992c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
# Maintainer: Tobias Bachmann <tobachmann@gmx.de>
pkgname=scantools
-pkgver=1.0.2
+pkgver=1.0.5
pkgrel=1
pkgdesc="scantools is a library and a matching set of command line applications for graphics manipulation, written with a view towards the handling of scanned documents and generation of high-quality PDF files."
arch=('x86_64')
-url="https://cplx.vm.uni-freiburg.de/scantools/"
+url="https://kebekus.gitlab.io/scantools/"
license=('GPL')
-depends=('qpdf' 'qt5-imageformats' 'gcc' 'graphviz' 'jbig2dec' 'libjpeg-turbo' 'libtiff' 'openjpeg2' 'tesseract' 'qpdf' 'qt5-base' 'zlib' 'poppler-qt5')
+depends=('qpdf' 'qt5-imageformats' 'gcc' 'graphviz' 'jbig2dec' 'libjpeg-turbo' 'libtiff' 'openjpeg2' 'tesseract' 'qpdf' 'qt5-base' 'zlib' 'poppler-qt5' 'zopfli')
makedepends=('cmake' 'doxygen' 'git')
+optdepends=('jbig2enc-git: Encode PDF files with JBIG2 (recommended)')
source=("https://gitlab.com/kebekus/scantools/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('7621e22dee47bf22b260b31cd55aa4bad94bcbdd4ac75e0ede5aca5756de5b64')
+sha256sums=('556d76ab71b34ebfa44f216b12b409715c7f94e9e14f04205836d662ea36ad0a')
build() {
cd ${pkgname}-${pkgver}