summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Gräb2015-09-20 12:21:34 +0200
committerMarkus Gräb2015-09-20 12:21:34 +0200
commit44a29a1935017c20a95fb1121644baf91a706a8b (patch)
treec2182c8bfc1e7046e4ec559edad48f35160480d0
downloadaur-44a29a1935017c20a95fb1121644baf91a706a8b.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4065f48364f0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = scapy3k-git
+ pkgdesc = scapy for python3 (aka scapy3k)
+ pkgver = r170.1be81b9
+ pkgrel = 1
+ url = https://github.com/phaethon/scapy
+ arch = any
+ license = GPLv2
+ makedepends = git
+ depends = python
+ conflicts = scapy
+ source = git+https://github.com/phaethon/scapy.git
+ md5sums = SKIP
+
+pkgname = scapy3k-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..beabae49874f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Markus Gräb <m_graeb11@cs.uni-kl.de>
+pkgname=scapy3k-git
+pkgver=r170.1be81b9
+pkgrel=1
+pkgdesc="scapy for python3 (aka scapy3k)"
+arch=('any')
+url="https://github.com/phaethon/scapy"
+license=('GPLv2')
+groups=()
+depends=('python')
+makedepends=('git')
+source=('git+https://github.com/phaethon/scapy.git')
+md5sums=('SKIP')
+conflicts=('scapy')
+
+pkgver() {
+ cd "$srcdir/scapy"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/scapy"
+ python setup.py install --root=$pkgdir --optimize=1
+}