summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-10-12 00:13:06 -0400
committerJean Lucas2019-10-12 00:18:02 -0400
commit2fa721a9a1a53f20de12254cb180ec159729903a (patch)
tree5c3be511b991b72fed4fba48faed58b6e9661555
parent3b767824f1bc00387ba19bb5ac4cfd3d59b78b52 (diff)
downloadaur-2fa721a9a1a53f20de12254cb180ec159729903a.tar.gz
0.2.12
- Move openssl-1.0 to checkdeps - Build all features - Tests with all features is currently broken, so run default tests on debug build so as to not overwrite release build - Manually install sccache bin since running 'cargo install' starts another build from scratch
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a22f25290af4..3cc1c721c35e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = sccache
pkgdesc = ccache with cloud storage
- pkgver = 0.2.10
+ pkgver = 0.2.12
pkgrel = 1
url = https://github.com/mozilla/sccache
arch = i686
arch = x86_64
license = Apache
+ checkdepends = openssl-1.0
makedepends = cargo
- makedepends = openssl-1.0
depends = openssl
- source = sccache-0.2.10.tar.gz::https://github.com/mozilla/sccache/archive/0.2.10.tar.gz
- sha512sums = 4f4c051e93d937bae42739d9030dddddde48af59d66c69256172ad660e8d6135c64a77421174b98d304ddff9949d33a04e84e05c255ceccc73cd9cab32663989
+ source = sccache-0.2.12.tar.gz::https://github.com/mozilla/sccache/archive/0.2.12.tar.gz
+ sha512sums = 1f7495aa7c0749c4bfbd85a88a304a6ed18cc9bfcd341f0f1a668a743ae31d355bc8c5b3199b048d8bcab3ce8e9c8b844a609e4c3009d4e5497dd080aa881a45
pkgname = sccache
diff --git a/PKGBUILD b/PKGBUILD
index ca6873b9dade..02a224a1d60d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,34 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=sccache
-pkgver=0.2.10
+pkgver=0.2.12
pkgrel=1
pkgdesc='ccache with cloud storage'
arch=(i686 x86_64)
url=https://github.com/mozilla/sccache
license=(Apache)
depends=(openssl)
-makedepends=(cargo openssl-1.0)
+makedepends=(cargo)
+checkdepends=(openssl-1.0)
source=(sccache-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz)
-sha512sums=('4f4c051e93d937bae42739d9030dddddde48af59d66c69256172ad660e8d6135c64a77421174b98d304ddff9949d33a04e84e05c255ceccc73cd9cab32663989')
+sha512sums=('1f7495aa7c0749c4bfbd85a88a304a6ed18cc9bfcd341f0f1a668a743ae31d355bc8c5b3199b048d8bcab3ce8e9c8b844a609e4c3009d4e5497dd080aa881a45')
build() {
cd sccache-$pkgver
- cargo build --release
+ cargo build --all-features --release
}
check() {
cd sccache-$pkgver
- # native-tls crate depends on older openssl crate
+ # Older native-tls crate depends on older openssl crate
OPENSSL_LIB_DIR=/usr/lib/openssl-1.0 \
OPENSSL_INCLUDE_DIR=/usr/include/openssl-1.0 \
- cargo test --release
+ cargo test
}
package() {
cd sccache-$pkgver
-
- cargo install --path . --root "$pkgdir"/usr
- rm "$pkgdir"/usr/.crates.toml # Remove unneeded file
-
+ install -D target/release/sccache -t "$pkgdir"/usr/bin
install -Dm 644 README.md -t "$pkgdir"/usr/share/doc/sccache
install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/sccache
}