summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12020-02-19 14:24:41 +0800
committerChocobo12020-02-19 14:45:13 +0800
commit34726a8d55fe648c0a73d21288c77614033f3d99 (patch)
treebcbd297dbf21d906fbddf31d957606378aeb7833
parent1427a078d7e36288cc78875870094c3fa013977e (diff)
downloadaur-34726a8d55fe648c0a73d21288c77614033f3d99.tar.gz
upgpkg: sccache 0.2.12-3
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD59
2 files changed, 28 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1cd55e98663..0f69ed7ae8a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = sccache
- pkgdesc = ccache with cloud storage
+ pkgdesc = Shared compilation cache
pkgver = 0.2.12
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/mozilla/sccache
+ arch = i686
arch = x86_64
- arch = aarch64
- license = Apache
- checkdepends = openssl-1.0
- makedepends = cargo
+ license = apache
+ makedepends = rust
depends = openssl
source = sccache-0.2.12.tar.gz::https://github.com/mozilla/sccache/archive/0.2.12.tar.gz
- sha512sums = 1f7495aa7c0749c4bfbd85a88a304a6ed18cc9bfcd341f0f1a668a743ae31d355bc8c5b3199b048d8bcab3ce8e9c8b844a609e4c3009d4e5497dd080aa881a45
+ sha256sums = 591a82ddbc2e970630a9426c78c25cbc52c3261b06d57cb4e1f11ab8008629fa
pkgname = sccache
diff --git a/PKGBUILD b/PKGBUILD
index a9ce1e65dc7a..3643d5dfb367 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,33 @@
-# Maintainer: Jean Lucas <jean@4ray.co>
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+# Former maintainer: Jean Lucas <jean@4ray.co>
pkgname=sccache
pkgver=0.2.12
-pkgrel=2
-pkgdesc='ccache with cloud storage'
-arch=(x86_64 aarch64)
-url=https://github.com/mozilla/sccache
-license=(Apache)
-depends=(openssl)
-makedepends=(cargo)
-checkdepends=(openssl-1.0)
-source=(sccache-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz)
-sha512sums=('1f7495aa7c0749c4bfbd85a88a304a6ed18cc9bfcd341f0f1a668a743ae31d355bc8c5b3199b048d8bcab3ce8e9c8b844a609e4c3009d4e5497dd080aa881a45')
+pkgrel=3
+pkgdesc="Shared compilation cache"
+arch=('i686' 'x86_64')
+url="https://github.com/mozilla/sccache"
+license=('apache')
+depends=('openssl')
+makedepends=('rust')
+#checkdepends=('openssl-1.0')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/mozilla/sccache/archive/$pkgver.tar.gz")
+sha256sums=('591a82ddbc2e970630a9426c78c25cbc52c3261b06d57cb4e1f11ab8008629fa')
-prepare() {
- # Lifetime annotation is required for the version-compare crate with Rust 1.40
- # Upgrade it to 0.0.9 which added the annotation
- sed -r "s@(version-compare = \{ version = \")(.*)(\".*)@\10.0.9\3@" \
- -i sccache-$pkgver/Cargo.toml
-}
-
-build() {
- cd sccache-$pkgver
- # sccache-dist is only supported on x86_64
- cargo build \
- $([ $CARCH = aarch64 ] && echo --features=all || echo --all-features) \
- --release
-}
check() {
- # Tests require sccache-dist. Disable for now.
- [ $CARCH = aarch64 ] && return
+ cd "$pkgname-$pkgver"
- cd sccache-$pkgver
-
- # Older native-tls crate depends on older openssl crate
- OPENSSL_LIB_DIR=/usr/lib/openssl-1.0 \
- OPENSSL_INCLUDE_DIR=/usr/include/openssl-1.0 \
- cargo test --release
+ #OPENSSL_LIB_DIR="/usr/lib/openssl-1.0" \
+ # OPENSSL_INCLUDE_DIR="/usr/include/openssl-1.0" \
+ # cargo test --release
}
package() {
- cd sccache-$pkgver
- install -D target/release/sccache -t "$pkgdir"/usr/bin
- install -Dm 644 README.md -t "$pkgdir"/usr/share/doc/sccache
- install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/sccache
+ cd "$pkgname-$pkgver"
+
+ cargo install --root "$pkgdir/usr" --path "$srcdir/$pkgname-$pkgver"
+ install -Dm644 "README.md" -t "$pkgdir/usr/share/doc/sccache"
+
+ rm -f "$pkgdir/usr"/.crates*
}