summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-08-13 21:34:30 -0400
committerJean Lucas2019-08-13 21:34:30 -0400
commit3b767824f1bc00387ba19bb5ac4cfd3d59b78b52 (patch)
treeff2c8f3d6dde57de6da4bc9c03d452dcf0d3f2d3
parentd5286ade10897e0bb4f4a665d383604c4a6e16ae (diff)
downloadaur-3b767824f1bc00387ba19bb5ac4cfd3d59b78b52.tar.gz
0.2.10
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 781dd00f111b..a22f25290af4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sccache
pkgdesc = ccache with cloud storage
- pkgver = 0.2.9
- pkgrel = 2
+ pkgver = 0.2.10
+ pkgrel = 1
url = https://github.com/mozilla/sccache
arch = i686
arch = x86_64
@@ -9,8 +9,8 @@ pkgbase = sccache
makedepends = cargo
makedepends = openssl-1.0
depends = openssl
- source = sccache-0.2.9.tar.gz::https://github.com/mozilla/sccache/archive/0.2.9.tar.gz
- sha512sums = 289109338913c935752e9bbcd45b7bf4ef48be03b5a7d92c93ac220b98f04338ff562030cf126f80bda8db41e83b1103e6c2bd55caaeef4d7804157f4f685080
+ source = sccache-0.2.10.tar.gz::https://github.com/mozilla/sccache/archive/0.2.10.tar.gz
+ sha512sums = 4f4c051e93d937bae42739d9030dddddde48af59d66c69256172ad660e8d6135c64a77421174b98d304ddff9949d33a04e84e05c255ceccc73cd9cab32663989
pkgname = sccache
diff --git a/PKGBUILD b/PKGBUILD
index 5a799ef40f53..ca6873b9dade 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=sccache
-pkgver=0.2.9
-pkgrel=2
+pkgver=0.2.10
+pkgrel=1
pkgdesc='ccache with cloud storage'
arch=(i686 x86_64)
url=https://github.com/mozilla/sccache
@@ -10,7 +10,7 @@ license=(Apache)
depends=(openssl)
makedepends=(cargo openssl-1.0)
source=(sccache-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz)
-sha512sums=('289109338913c935752e9bbcd45b7bf4ef48be03b5a7d92c93ac220b98f04338ff562030cf126f80bda8db41e83b1103e6c2bd55caaeef4d7804157f4f685080')
+sha512sums=('4f4c051e93d937bae42739d9030dddddde48af59d66c69256172ad660e8d6135c64a77421174b98d304ddff9949d33a04e84e05c255ceccc73cd9cab32663989')
build() {
cd sccache-$pkgver
@@ -27,8 +27,10 @@ check() {
package() {
cd sccache-$pkgver
+
cargo install --path . --root "$pkgdir"/usr
- rm "$pkgdir"/usr/.crates.toml
+ rm "$pkgdir"/usr/.crates.toml # Remove unneeded file
+
install -Dm 644 README.md -t "$pkgdir"/usr/share/doc/sccache
install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/sccache
}