summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-07-06 00:45:54 -0400
committerJean Lucas2019-07-06 04:57:20 -0400
commitd5286ade10897e0bb4f4a665d383604c4a6e16ae (patch)
treea2264dec2643749569924db7ee58b32f4cd9a0f2
parent68bc4cf0f08ca4d1d8daecc1e393bd5e31586732 (diff)
downloadaur-d5286ade10897e0bb4f4a665d383604c4a6e16ae.tar.gz
Add openssl to depends and openssl-1.0 to makedepends. Latter fixes
check. Update package naming scheme.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e64790eb0e2..781dd00f111b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = sccache
pkgdesc = ccache with cloud storage
pkgver = 0.2.9
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/mozilla/sccache
arch = i686
arch = x86_64
license = Apache
makedepends = cargo
- source = https://github.com/mozilla/sccache/archive/0.2.9.tar.gz
+ makedepends = openssl-1.0
+ depends = openssl
+ source = sccache-0.2.9.tar.gz::https://github.com/mozilla/sccache/archive/0.2.9.tar.gz
sha512sums = 289109338913c935752e9bbcd45b7bf4ef48be03b5a7d92c93ac220b98f04338ff562030cf126f80bda8db41e83b1103e6c2bd55caaeef4d7804157f4f685080
pkgname = sccache
diff --git a/PKGBUILD b/PKGBUILD
index 7eaaf6651fa7..5a799ef40f53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,14 @@
pkgname=sccache
pkgver=0.2.9
-pkgrel=1
+pkgrel=2
pkgdesc='ccache with cloud storage'
arch=(i686 x86_64)
url=https://github.com/mozilla/sccache
license=(Apache)
-makedepends=(cargo)
-source=($url/archive/$pkgver.tar.gz)
+depends=(openssl)
+makedepends=(cargo openssl-1.0)
+source=(sccache-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz)
sha512sums=('289109338913c935752e9bbcd45b7bf4ef48be03b5a7d92c93ac220b98f04338ff562030cf126f80bda8db41e83b1103e6c2bd55caaeef4d7804157f4f685080')
build() {
@@ -18,7 +19,10 @@ build() {
check() {
cd sccache-$pkgver
- cargo test --release || true
+ # native-tls crate depends on older openssl crate
+ OPENSSL_LIB_DIR=/usr/lib/openssl-1.0 \
+ OPENSSL_INCLUDE_DIR=/usr/include/openssl-1.0 \
+ cargo test --release
}
package() {