summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcyrant2018-09-18 03:12:50 +0400
committercyrant2018-09-18 03:12:50 +0400
commit08df73a6fb4f4f0de0394829f53a5c2e5bfcc4ae (patch)
tree0dd458ee6992c9c4bda685e73f5b8d334025ee4a
parentca8306835570419edc4d7ba93faa946b157ba1f3 (diff)
downloadaur-08df73a6fb4f4f0de0394829f53a5c2e5bfcc4ae.tar.gz
update to 0.7.2.beta9
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
-rw-r--r--build.patch60
-rw-r--r--scenarist.desktop13
-rw-r--r--scenarist.pngbin33927 -> 0 bytes
-rw-r--r--scenarist.sh3
6 files changed, 26 insertions, 87 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b76988501863..6eb943c224ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = scenarist
pkgdesc = Screenwriting software, which developed in Russia.
- pkgver = 0.7.2.beta8
- pkgrel = 2
+ pkgver = 0.7.2.beta9
+ pkgrel = 1
url = https://kitscenarist.ru
arch = x86_64
license = GPL3
@@ -9,16 +9,10 @@ pkgbase = scenarist
depends = qt5-multimedia
depends = qt5-svg
depends = qt5-webengine
- source = scenarist::git+https://github.com/dimkanovikov/KITScenarist.git#tag=0.7.2.beta8
+ source = scenarist::git+https://github.com/dimkanovikov/KITScenarist.git#tag=0.7.2.beta9
source = build.patch
- source = scenarist.desktop
- source = scenarist.png
- source = scenarist.sh
md5sums = SKIP
- md5sums = b7c67d596a36ac3c45e58d64da1cf2bc
- md5sums = fda5daa58cdf45b83eb6be4585bfda0f
- md5sums = 675823c4359fef11810a0229d1f69466
- md5sums = e73bb78f9e7a2de9dbc0abe6c6d3ac78
+ md5sums = 5a400771b9a0665aacfc773a18548628
pkgname = scenarist
diff --git a/PKGBUILD b/PKGBUILD
index 7d16d49322a9..f134a86cf457 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: cyrant <cyrant at tuta dot io>
pkgname=scenarist
-pkgver=0.7.2.beta8
-pkgrel=2
+pkgver=0.7.2.beta9
+pkgrel=1
pkgdesc='Screenwriting software, which developed in Russia.'
url='https://kitscenarist.ru'
arch=('x86_64')
@@ -12,16 +12,10 @@ makedepends=('git')
source=(
"${pkgname}::git+https://github.com/dimkanovikov/KITScenarist.git#tag=${pkgver}"
"build.patch"
- "${pkgname}.desktop"
- "${pkgname}.png"
- "${pkgname}.sh"
)
md5sums=(
'SKIP'
- 'b7c67d596a36ac3c45e58d64da1cf2bc'
- 'fda5daa58cdf45b83eb6be4585bfda0f'
- '675823c4359fef11810a0229d1f69466'
- 'e73bb78f9e7a2de9dbc0abe6c6d3ac78'
+ '5a400771b9a0665aacfc773a18548628'
)
prepare() {
@@ -37,10 +31,9 @@ build() {
}
package() {
- install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- install -Dm644 "${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
- install -Dm755 "${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
- install -Dm755 "${pkgname}/build/Release/bin/scenarist-desktop/Scenarist" "${pkgdir}/usr/lib/${pkgname}/${pkgname}"
- cd "${pkgname}/build/Release/libs"
- find . -name '*.so*' -exec cp -dp --no-preserve=ownership -t "${pkgdir}/usr/lib/${pkgname}" '{}' \+
+ install -Dm755 "${pkgname}/build/Release/bin/scenarist-desktop/Scenarist" "${pkgdir}/usr/bin/${pkgname}"
+
+ cd "${pkgname}/build/Ubuntu/scenarist_amd64/usr/share"
+ install -Dm644 "applications/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 "pixmaps/${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
}
diff --git a/build.patch b/build.patch
index 4965b93f7f98..9f8738c94413 100644
--- a/build.patch
+++ b/build.patch
@@ -1,46 +1,14 @@
-diff --git a/src/bin/scenarist-desktop/UserInterfaceLayer/Account/LoginDialog.cpp b/src/bin/scenarist-desktop/UserInterfaceLayer/Account/LoginDialog.cpp
-index 2b8d5694..816f4c95 100755
---- a/src/bin/scenarist-desktop/UserInterfaceLayer/Account/LoginDialog.cpp
-+++ b/src/bin/scenarist-desktop/UserInterfaceLayer/Account/LoginDialog.cpp
-@@ -20,6 +20,8 @@
-
- #include <3rd_party/Helpers/Validators.h>
-
-+#include <QStyle>
-+
- using UserInterface::LoginDialog;
-
- namespace {
-diff --git a/src/bin/scenarist-desktop/UserInterfaceLayer/Export/ExportDialog.cpp b/src/bin/scenarist-desktop/UserInterfaceLayer/Export/ExportDialog.cpp
-index 49e98c1c..21d883ae 100755
---- a/src/bin/scenarist-desktop/UserInterfaceLayer/Export/ExportDialog.cpp
-+++ b/src/bin/scenarist-desktop/UserInterfaceLayer/Export/ExportDialog.cpp
-@@ -1,3 +1,4 @@
-+#include <QButtonGroup>
- #include "ExportDialog.h"
- #include "ui_ExportDialog.h"
-
-diff --git a/src/bin/scenarist-desktop/UserInterfaceLayer/Onboarding/OnboardingView.cpp b/src/bin/scenarist-desktop/UserInterfaceLayer/Onboarding/OnboardingView.cpp
-index 1e6e0131..7a40490f 100644
---- a/src/bin/scenarist-desktop/UserInterfaceLayer/Onboarding/OnboardingView.cpp
-+++ b/src/bin/scenarist-desktop/UserInterfaceLayer/Onboarding/OnboardingView.cpp
-@@ -3,6 +3,7 @@
-
- #include <3rd_party/Widgets/WAF/StackedWidgetAnimation/StackedWidgetAnimation.h>
-
-+#include <QButtonGroup>
- #include <QDesktopWidget>
- #include <QScreen>
- #include <QTimer>
-diff --git a/src/bin/scenarist-desktop/UserInterfaceLayer/_tools/UIConfigurator.cpp b/src/bin/scenarist-desktop/UserInterfaceLayer/_tools/UIConfigurator.cpp
-index 1e1d9566..bcf0cc29 100644
---- a/src/bin/scenarist-desktop/UserInterfaceLayer/_tools/UIConfigurator.cpp
-+++ b/src/bin/scenarist-desktop/UserInterfaceLayer/_tools/UIConfigurator.cpp
-@@ -10,6 +10,7 @@
- #include <QFileDialog>
- #include <QPalette>
- #include <QStandardPaths>
-+#include <QStyle>
- #include <QStyleFactory>
-
-
+diff --git a/src/bin/scenarist-desktop.pro b/src/bin/scenarist-desktop.pro
+index a93db297..3973e755 100755
+--- a/src/bin/scenarist-desktop.pro
++++ b/src/bin/scenarist-desktop.pro
+@@ -64,6 +64,9 @@ DEPENDPATH += $$PWD/../libs/hunspell
+ # Подключаем библиотеку fileformats
+ #
+ LIBS += -L$$DESTDIR/../../libs/fileformats/ -lfileformats
++unix {
++LIBS += -lz
++}
+
+ INCLUDEPATH += $$PWD/../libs/fileformats
+ DEPENDPATH += $$PWD/../libs/fileformats
diff --git a/scenarist.desktop b/scenarist.desktop
deleted file mode 100644
index a545c6f5d65d..000000000000
--- a/scenarist.desktop
+++ /dev/null
@@ -1,13 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Name=KIT Scenarist
-Name[ru]=КИТ Сценарист
-Comment=Screenwriting software
-Comment[ru]=Программа для написания сценариев
-Exec=scenarist %f
-Icon=scenarist
-MimeType=application/x-kit-scenarist-project;
-Terminal=false
-Type=Application
-StartupNotify=true
-Categories=Office;
diff --git a/scenarist.png b/scenarist.png
deleted file mode 100644
index 051e7eedb818..000000000000
--- a/scenarist.png
+++ /dev/null
Binary files differ
diff --git a/scenarist.sh b/scenarist.sh
deleted file mode 100644
index 23c5cf34d332..000000000000
--- a/scenarist.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-export LD_LIBRARY_PATH="/usr/lib/scenarist:$LD_LIBRARY_PATH"
-exec /usr/lib/scenarist/scenarist "$@"