summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcyrant2016-11-02 18:51:16 +0300
committercyrant2016-11-02 18:51:16 +0300
commit82c93fd3ba2fe41f6a203c22ccf4fe524f901978 (patch)
tree998b5197ebd9b139fcb37cd7ec7721c3e79e8607
downloadaur-82c93fd3ba2fe41f6a203c22ccf4fe524f901978.tar.gz
initial
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD37
-rw-r--r--scenarist.desktop13
-rw-r--r--scenarist.pngbin0 -> 21480 bytes
-rw-r--r--scenarist.sh3
6 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..251c88dcf786
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = scenarist
+ pkgdesc = Screenwriting software, which developed in Russia.
+ pkgver = 0.6.2
+ pkgrel = 1
+ url = https://kitscenarist.ru
+ arch = x86_64
+ license = GPL3
+ depends = qt5-webengine
+ source = scenarist::git+https://github.com/dimkanovikov/KITScenarist.git#tag=0.6.2
+ source = scenarist.desktop
+ source = scenarist.png
+ source = scenarist.sh
+ md5sums = SKIP
+ md5sums = fda5daa58cdf45b83eb6be4585bfda0f
+ md5sums = e1414aa48f5f87e3df94f5da8c404ee4
+ md5sums = e73bb78f9e7a2de9dbc0abe6c6d3ac78
+
+pkgname = scenarist
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..019f92a0b6be
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!*.desktop
+!*.png
+!*.sh
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c03539bf68f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: cyrant <cyrant at tuta dot io>
+
+pkgname=scenarist
+pkgver=0.6.2
+pkgrel=1
+pkgdesc='Screenwriting software, which developed in Russia.'
+url='https://kitscenarist.ru'
+arch=('x86_64')
+license=('GPL3')
+depends=('qt5-webengine')
+source=(
+ "${pkgname}::git+https://github.com/dimkanovikov/KITScenarist.git#tag=${pkgver}"
+ "${pkgname}.desktop"
+ "${pkgname}.png"
+ "${pkgname}.sh"
+)
+md5sums=(
+ 'SKIP'
+ 'fda5daa58cdf45b83eb6be4585bfda0f'
+ 'e1414aa48f5f87e3df94f5da8c404ee4'
+ 'e73bb78f9e7a2de9dbc0abe6c6d3ac78'
+)
+
+build() {
+ cd "${pkgname}/src"
+ qmake Scenarist.pro -spec linux-g++ &&
+ make
+}
+
+package() {
+ install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 "${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm755 "${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm755 "${pkgname}/build/Release/bin/scenarist-desktop/Scenarist" "${pkgdir}/usr/lib/${pkgname}/${pkgname}"
+ cd "${pkgname}/build/Release/libs"
+ find . -name '*.so*' -exec cp -dp --no-preserve=ownership -t "${pkgdir}/usr/lib/${pkgname}" '{}' \+
+}
diff --git a/scenarist.desktop b/scenarist.desktop
new file mode 100644
index 000000000000..a545c6f5d65d
--- /dev/null
+++ b/scenarist.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Version=1.0
+Name=KIT Scenarist
+Name[ru]=КИТ Сценарист
+Comment=Screenwriting software
+Comment[ru]=Программа для написания сценариев
+Exec=scenarist %f
+Icon=scenarist
+MimeType=application/x-kit-scenarist-project;
+Terminal=false
+Type=Application
+StartupNotify=true
+Categories=Office;
diff --git a/scenarist.png b/scenarist.png
new file mode 100644
index 000000000000..9cf5a89b4e16
--- /dev/null
+++ b/scenarist.png
Binary files differ
diff --git a/scenarist.sh b/scenarist.sh
new file mode 100644
index 000000000000..23c5cf34d332
--- /dev/null
+++ b/scenarist.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+export LD_LIBRARY_PATH="/usr/lib/scenarist:$LD_LIBRARY_PATH"
+exec /usr/lib/scenarist/scenarist "$@"