summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcyrant2019-09-19 21:14:22 +0400
committercyrant2019-09-19 21:14:22 +0400
commita190d5bb64238812c55c985812972823d1c697ca (patch)
tree963aed349b4ea71636e2dfd554e5138db3f2bd07
parent9ea13e80744935c558ba8e50dbb11b372b32278f (diff)
downloadaur-a190d5bb64238812c55c985812972823d1c697ca.tar.gz
update to 0.7.2.rc9a
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
-rw-r--r--build.patch9
-rw-r--r--scenarist.mime.xml (renamed from mime.xml)0
4 files changed, 13 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91b015a4c015..4869fb840821 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = scenarist
pkgdesc = A professional screenwriting software.
- pkgver = 0.7.2.rc9
+ pkgver = 0.7.2.rc9a
pkgrel = 1
url = https://kitscenarist.ru/en/
arch = x86_64
@@ -10,12 +10,10 @@ pkgbase = scenarist
depends = desktop-file-utils
depends = qt5-multimedia
depends = qt5-webengine
- source = scenarist::git+https://github.com/dimkanovikov/KITScenarist.git#tag=0.7.2.rc9
- source = mime.xml
- source = build.patch
- md5sums = SKIP
- md5sums = 45018aa6c472835db014c62a80f5b6dc
- md5sums = da0f40d723f2d15f888bf3197351da3d
+ source = scenarist::git+https://github.com/dimkanovikov/KITScenarist.git#tag=0.7.2.rc9a
+ source = scenarist.mime.xml
+ sha256sums = SKIP
+ sha256sums = 513987794f8ba5a4c12aa2a65314fccdc098f86e616a416977aead29e6545b63
pkgname = scenarist
diff --git a/PKGBUILD b/PKGBUILD
index b251e5cc1db4..8e935225e830 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: cyrant <cyrant at tuta dot io>
pkgname=scenarist
-pkgver=0.7.2.rc9
+pkgver=0.7.2.rc9a
pkgrel=1
pkgdesc='A professional screenwriting software.'
url='https://kitscenarist.ru/en/'
@@ -11,19 +11,16 @@ depends=('desktop-file-utils' 'qt5-multimedia' 'qt5-webengine')
makedepends=('git' 'qt5-svg')
source=(
"${pkgname}::git+https://github.com/dimkanovikov/KITScenarist.git#tag=${pkgver}"
- 'mime.xml'
- 'build.patch'
+ "${pkgname}.mime.xml"
)
-md5sums=(
+sha256sums=(
'SKIP'
- '45018aa6c472835db014c62a80f5b6dc'
- 'da0f40d723f2d15f888bf3197351da3d'
+ '513987794f8ba5a4c12aa2a65314fccdc098f86e616a416977aead29e6545b63'
)
prepare() {
cd "${pkgname}"
git submodule update --init
- git apply "${srcdir}/build.patch"
}
build() {
@@ -34,9 +31,11 @@ build() {
package() {
install -Dm755 "${pkgname}/build/Release/bin/scenarist-desktop/Scenarist" "${pkgdir}/usr/bin/${pkgname}"
-
+
cd "${pkgname}/build/Ubuntu/scenarist_amd64/usr/share"
install -Dm644 "applications/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
install -Dm644 "pixmaps/${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
- install -Dm644 "${srcdir}/mime.xml" "${pkgdir}/usr/share/mime/packages/${pkgname}.xml"
+
+ cd "${srcdir}"
+ install -Dm644 "${pkgname}.mime.xml" "${pkgdir}/usr/share/mime/packages/${pkgname}.xml"
}
diff --git a/build.patch b/build.patch
deleted file mode 100644
index f4390faf8201..000000000000
--- a/build.patch
+++ /dev/null
@@ -1,9 +0,0 @@
-diff --git a/src/bin/scenarist-desktop.pro b/src/bin/scenarist-desktop.pro
-index d43f53fa..22a4369c 100755
---- a/src/bin/scenarist-desktop.pro
-+++ b/src/bin/scenarist-desktop.pro
-@@ -12,4 +12,3 @@ TARGET = Scenarist
-
- CONFIG += c++11 warn_on
--unix: QMAKE_CXXFLAGS_WARN_ON += -Werror
-
diff --git a/mime.xml b/scenarist.mime.xml
index e04d418cbafe..e04d418cbafe 100644
--- a/mime.xml
+++ b/scenarist.mime.xml