summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcyrant2018-06-19 16:37:37 +0400
committercyrant2018-06-19 16:37:37 +0400
commitca8306835570419edc4d7ba93faa946b157ba1f3 (patch)
treeb5ab61c0fb3c83f4bd9fe18234c7450d37330297
parentaf6a012e405da97041051c633e943eecb5ea3a50 (diff)
downloadaur-ca8306835570419edc4d7ba93faa946b157ba1f3.tar.gz
add build.patch
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD10
-rw-r--r--build.patch46
4 files changed, 54 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6774743e4e39..b76988501863 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = scenarist
pkgdesc = Screenwriting software, which developed in Russia.
pkgver = 0.7.2.beta8
- pkgrel = 1
+ pkgrel = 2
url = https://kitscenarist.ru
arch = x86_64
license = GPL3
@@ -10,10 +10,12 @@ pkgbase = scenarist
depends = qt5-svg
depends = qt5-webengine
source = scenarist::git+https://github.com/dimkanovikov/KITScenarist.git#tag=0.7.2.beta8
+ source = build.patch
source = scenarist.desktop
source = scenarist.png
source = scenarist.sh
md5sums = SKIP
+ md5sums = b7c67d596a36ac3c45e58d64da1cf2bc
md5sums = fda5daa58cdf45b83eb6be4585bfda0f
md5sums = 675823c4359fef11810a0229d1f69466
md5sums = e73bb78f9e7a2de9dbc0abe6c6d3ac78
diff --git a/.gitignore b/.gitignore
index 019f92a0b6be..bf2605b5887f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,5 +3,6 @@
!.SRCINFO
!PKGBUILD
!*.desktop
+!*.patch
!*.png
!*.sh
diff --git a/PKGBUILD b/PKGBUILD
index 11d4612d7e14..7d16d49322a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=scenarist
pkgver=0.7.2.beta8
-pkgrel=1
+pkgrel=2
pkgdesc='Screenwriting software, which developed in Russia.'
url='https://kitscenarist.ru'
arch=('x86_64')
@@ -11,12 +11,14 @@ depends=('qt5-multimedia' 'qt5-svg' 'qt5-webengine')
makedepends=('git')
source=(
"${pkgname}::git+https://github.com/dimkanovikov/KITScenarist.git#tag=${pkgver}"
+ "build.patch"
"${pkgname}.desktop"
"${pkgname}.png"
"${pkgname}.sh"
)
md5sums=(
'SKIP'
+ 'b7c67d596a36ac3c45e58d64da1cf2bc'
'fda5daa58cdf45b83eb6be4585bfda0f'
'675823c4359fef11810a0229d1f69466'
'e73bb78f9e7a2de9dbc0abe6c6d3ac78'
@@ -25,11 +27,7 @@ md5sums=(
prepare() {
cd "${pkgname}"
git submodule update --init
-
- # error: invalid use of incomplete type ‘class QClassName’
- cd "${srcdir}/${pkgname}/src/bin/scenarist-desktop/UserInterfaceLayer"
- sed -i '1 s/^/#include <QButtonGroup>\n/' "Export/ExportDialog.cpp" "Onboarding/OnboardingView.cpp"
- sed -i '1 s/^/#include <QStyle>\n/' "Account/LoginDialog.cpp" "_tools/UIConfigurator.cpp"
+ git apply "${srcdir}/build.patch"
}
build() {
diff --git a/build.patch b/build.patch
new file mode 100644
index 000000000000..4965b93f7f98
--- /dev/null
+++ b/build.patch
@@ -0,0 +1,46 @@
+diff --git a/src/bin/scenarist-desktop/UserInterfaceLayer/Account/LoginDialog.cpp b/src/bin/scenarist-desktop/UserInterfaceLayer/Account/LoginDialog.cpp
+index 2b8d5694..816f4c95 100755
+--- a/src/bin/scenarist-desktop/UserInterfaceLayer/Account/LoginDialog.cpp
++++ b/src/bin/scenarist-desktop/UserInterfaceLayer/Account/LoginDialog.cpp
+@@ -20,6 +20,8 @@
+
+ #include <3rd_party/Helpers/Validators.h>
+
++#include <QStyle>
++
+ using UserInterface::LoginDialog;
+
+ namespace {
+diff --git a/src/bin/scenarist-desktop/UserInterfaceLayer/Export/ExportDialog.cpp b/src/bin/scenarist-desktop/UserInterfaceLayer/Export/ExportDialog.cpp
+index 49e98c1c..21d883ae 100755
+--- a/src/bin/scenarist-desktop/UserInterfaceLayer/Export/ExportDialog.cpp
++++ b/src/bin/scenarist-desktop/UserInterfaceLayer/Export/ExportDialog.cpp
+@@ -1,3 +1,4 @@
++#include <QButtonGroup>
+ #include "ExportDialog.h"
+ #include "ui_ExportDialog.h"
+
+diff --git a/src/bin/scenarist-desktop/UserInterfaceLayer/Onboarding/OnboardingView.cpp b/src/bin/scenarist-desktop/UserInterfaceLayer/Onboarding/OnboardingView.cpp
+index 1e6e0131..7a40490f 100644
+--- a/src/bin/scenarist-desktop/UserInterfaceLayer/Onboarding/OnboardingView.cpp
++++ b/src/bin/scenarist-desktop/UserInterfaceLayer/Onboarding/OnboardingView.cpp
+@@ -3,6 +3,7 @@
+
+ #include <3rd_party/Widgets/WAF/StackedWidgetAnimation/StackedWidgetAnimation.h>
+
++#include <QButtonGroup>
+ #include <QDesktopWidget>
+ #include <QScreen>
+ #include <QTimer>
+diff --git a/src/bin/scenarist-desktop/UserInterfaceLayer/_tools/UIConfigurator.cpp b/src/bin/scenarist-desktop/UserInterfaceLayer/_tools/UIConfigurator.cpp
+index 1e1d9566..bcf0cc29 100644
+--- a/src/bin/scenarist-desktop/UserInterfaceLayer/_tools/UIConfigurator.cpp
++++ b/src/bin/scenarist-desktop/UserInterfaceLayer/_tools/UIConfigurator.cpp
+@@ -10,6 +10,7 @@
+ #include <QFileDialog>
+ #include <QPalette>
+ #include <QStandardPaths>
++#include <QStyle>
+ #include <QStyleFactory>
+
+