summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxeruf2022-07-06 06:35:51 +0200
committerxeruf2022-07-06 06:35:51 +0200
commit9ae75f294621f5b62f1e0e5c8818c86ca8610a13 (patch)
treef9e746741bf1f2b15f8f327e9e99ef3a27784093
parentb57e0a58ce283c50bde457b782009194140b8c32 (diff)
downloadaur-9ae75f294621f5b62f1e0e5c8818c86ca8610a13.tar.gz
Pin to JDK 11
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD16
-rwxr-xr-xscenic-view2
4 files changed, 16 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 617317239f06..98a3bbd534c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = scenic-view
pkgdesc = A tool for analyzing the scenegraph of a JavaFX application
- pkgver = 8.7.0
+ pkgver = 11.0.2
pkgrel = 1
url = http://fxexperience.com/scenic-view/
arch = i686
arch = x86_64
license = GPL
- depends = java-runtime
- source = http://fxexperience.com/downloads/scenic-view-8.7.0
+ depends = jre11-openjdk-headless
+ depends = java11-openjfx
+ source = https://download.jonathangiles.net/downloads/scenic-view/scenicview-linux.zip
source = scenic-view
source = scenic-view.desktop
- sha256sums = 12f4a908dd39ab1cfe2f57cbc7a3802b65267c3b33cac34e554ffce69179be74
- sha256sums = e7523143f53fd2b4fb18a7cfb8acb9f2af02270cf3e751063b99268d10a5d48e
+ sha256sums = 913cbbb3a86e4fa948a09247179eb0d740208a109f73316b135af0ebd938eedc
+ sha256sums = 8cf67647a28f2eb2a67bb48283f7b01c5ce866be402df4953b2a2af6d3d50844
sha256sums = 7d1fb4e5a06a081b604e10acef772e809b0aa6a7c56edbfba8bce8af47cabd96
pkgname = scenic-view
-
diff --git a/.gitignore b/.gitignore
index f57a067b3ec5..72e8ffc0db8a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,7 +1 @@
-pkg
-src
-*.pkg.tar
-*.pkg.tar.xz
-*.jar
-
-scenic-view-*
+*
diff --git a/PKGBUILD b/PKGBUILD
index 4ad91657b505..825a02c683e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,27 @@
pkgname=scenic-view
-pkgver=8.7.0
+pkgver=11.0.2
pkgrel=1
pkgdesc='A tool for analyzing the scenegraph of a JavaFX application'
arch=('i686' 'x86_64')
url='http://fxexperience.com/scenic-view/'
license=('GPL')
-depends=('java-runtime')
-source=("http://fxexperience.com/downloads/scenic-view-${pkgver}"
+depends=('jre11-openjdk-headless' 'java11-openjfx')
+source=("https://download.jonathangiles.net/downloads/scenic-view/scenicview-linux.zip"
'scenic-view'
'scenic-view.desktop')
-sha256sums=('12f4a908dd39ab1cfe2f57cbc7a3802b65267c3b33cac34e554ffce69179be74'
- 'e7523143f53fd2b4fb18a7cfb8acb9f2af02270cf3e751063b99268d10a5d48e'
+sha256sums=('913cbbb3a86e4fa948a09247179eb0d740208a109f73316b135af0ebd938eedc'
+ '8cf67647a28f2eb2a67bb48283f7b01c5ce866be402df4953b2a2af6d3d50844'
'7d1fb4e5a06a081b604e10acef772e809b0aa6a7c56edbfba8bce8af47cabd96')
prepare() {
- jar xf scenicView.jar
+ unzip -o scenicview-linux.zip
}
package() {
- install -Dm644 scenicView.jar "$pkgdir/usr/share/java/scenic-view/scenicView.jar"
+ install -Dm644 "$srcdir/scenicview/lib/scenicview.jar" "$pkgdir/usr/share/java/scenic-view/scenicview.jar"
install -Dm755 scenic-view "$pkgdir/usr/bin/scenic-view"
install -Dm644 scenic-view.desktop "$pkgdir/usr/share/applications/scenic-view.desktop"
- install -Dm644 org/scenicview/view/images/ui/mglass.png "$pkgdir/usr/share/pixmaps/scenic-view.png"
+ #install -Dm644 org/scenicview/view/images/ui/mglass.png "$pkgdir/usr/share/pixmaps/scenic-view.png"
}
diff --git a/scenic-view b/scenic-view
index 0e42be04d319..f907587f39e5 100755
--- a/scenic-view
+++ b/scenic-view
@@ -1,2 +1,2 @@
#!/bin/sh
-exec /usr/bin/java -jar '/usr/share/java/scenic-view/scenicView.jar' "$@"
+exec /usr/lib/jvm/java-11-openjdk/bin/java --module-path /usr/lib/jvm/java-11-openjfx/lib --add-modules javafx.web,javafx.fxml,javafx.swing -jar '/usr/share/java/scenic-view/scenicview.jar' "$@"