summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuliette Monsel2020-02-03 11:45:18 +0100
committerJuliette Monsel2020-02-03 11:45:18 +0100
commit5d7d8a5cb728f04f792321f299dba204c4fd16d8 (patch)
treec72b8eb66376ebf190b7b5da956efaf17ed00dc1
parent04cb59453fc9ba55bde4b1280a04108d70dbd103 (diff)
downloadaur-scheduler.tar.gz
New upstream release - v1.2.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
-rw-r--r--scheduler.install14
3 files changed, 23 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07abc05f1d4d..81949ee3ca21 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = scheduler
pkgdesc = Alarms and reminders: tasks, events, calendar, pomodoro and timer widgets
- pkgver = 1.1.1
+ pkgver = 1.2.0
pkgrel = 1
url = https://github.com/j4321/Scheduler
+ install = scheduler.install
arch = any
license = GPL3
makedepends = python-setuptools
@@ -28,8 +29,8 @@ pkgbase = scheduler
optdepends = zenity: nicer color chooser and file browser
optdepends = python-tkcolorpicker: nicer color chooser
optdepends = python-tkfilebrowser: nicer file browser
- source = scheduler-1.1.1.tar.gz::https://github.com/j4321/Scheduler/archive/v1.1.1.tar.gz
- sha512sums = ab7d37c0b60f5577f6308938ed733edcab765eef671a96fd1a6eff9556159c5b32815b649558af9cb80da60be10a6ebdecbb52f6e11999a4bab6ac1ce235d8b2
+ source = scheduler-1.2.0.tar.gz::https://github.com/j4321/Scheduler/archive/v1.2.0.tar.gz
+ sha512sums = c762811b18bbdd503213c9a1e252c63bf0c46c0938c8f83d4b2d0d574b654e70a97b0faa040487c05366a9367b2a8e495bd2dfa54908da652d3e8996c955206c
pkgname = scheduler
diff --git a/PKGBUILD b/PKGBUILD
index 2a12a38dddd4..7a8bdca6a12a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Juliette Monsel <j_4321 at protonmail dot com>
pkgname=scheduler
-pkgver=1.1.1
+pkgver=1.2.0
pkgrel=1
pkgdesc="Alarms and reminders: tasks, events, calendar, pomodoro and timer widgets"
arch=('any')
@@ -21,7 +21,8 @@ optdepends=('tktray: GUI toolkit for the system tray icon (at least one must be
'python-tkcolorpicker: nicer color chooser'
'python-tkfilebrowser: nicer file browser')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/j4321/Scheduler/archive/v${pkgver}.tar.gz")
-sha512sums=('ab7d37c0b60f5577f6308938ed733edcab765eef671a96fd1a6eff9556159c5b32815b649558af9cb80da60be10a6ebdecbb52f6e11999a4bab6ac1ce235d8b2')
+sha512sums=('c762811b18bbdd503213c9a1e252c63bf0c46c0938c8f83d4b2d0d574b654e70a97b0faa040487c05366a9367b2a8e495bd2dfa54908da652d3e8996c955206c')
+install="$pkgname".install
build() {
cd "$srcdir/Scheduler-${pkgver}"
@@ -31,4 +32,6 @@ build() {
package() {
cd "$srcdir/Scheduler-${pkgver}"
python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1 --skip-build
+ install -d -m755 "$pkgdir/usr/lib/systemd/system"
+ install -m644 scheduler@.service "$pkgdir/usr/lib/systemd/system/"
}
diff --git a/scheduler.install b/scheduler.install
new file mode 100644
index 000000000000..6b89f9fbd1e3
--- /dev/null
+++ b/scheduler.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo "";
+ echo "NOTE: If you want the current day highlighted in the calendar to be updated on resume, enable the service scheduler@USERNAME with 'sudo systemctl enable scheduler@\$USER'";
+ echo "";
+}
+
+
+post_upgrade() {
+ if [ $2 /< "1.1.1-1" ]; then
+ echo "";
+ echo "NOTE: If you want the current day highlighted in the calendar to be updated on resume, enable the service scheduler@USERNAME with 'sudo systemctl enable scheduler@\$USER'";
+ echo "";
+ fi;
+}