summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSandro Kalbermatter2016-10-28 15:35:22 +0200
committerSandro Kalbermatter2016-10-28 15:35:22 +0200
commitbb079b2d9a8b8d65f5ff2e155e01ae379a757177 (patch)
tree8fccbe11d7a8003619977a57971d309d5f5c09d7
downloadaur-bb079b2d9a8b8d65f5ff2e155e01ae379a757177.tar.gz
initial commit for version 0.99
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD45
-rw-r--r--schemaspygui.install9
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..33a35542e322
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = schemaspygui
+ pkgdesc = Graphical user interface for the tool SchemaSpy from John Currier
+ pkgver = 0.99
+ pkgrel = 1
+ url = http://schemaspy.sourceforge.net/
+ install = schemaspygui.install
+ arch = any
+ license = LGPL
+ depends = java-runtime>=6,
+ depends = schemaspy,
+ depends = graphviz
+ provides = schemaspygui
+ source = schemaSpyGUI20090302.zip::http://downloads.sourceforge.net/project/schemaspygui/schemaspygui/SchemaSpyGUI%20Version%200.99%20%2820090302%29%20-%20Linux%20bugfix/schemaSpyGUI20090302.zip
+ md5sums = 997be6c1c5d7ce83dcce6a94380deeee
+
+pkgname = schemaspygui
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c6531f3a2da9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Sandro Kalbermatter <info.kalsan [ät-symbol] valaiscom.ch>
+pkgname=schemaspygui
+pkgver=0.99
+pkgrel=1
+pkgdesc="Graphical user interface for the tool SchemaSpy from John Currier"
+arch=(any)
+url="http://schemaspy.sourceforge.net/"
+license=(LGPL)
+depends=('java-runtime>=6', 'schemaspy', 'graphviz')
+provides=('schemaspygui')
+install=${pkgname}.install
+source=("schemaSpyGUI20090302.zip::http://downloads.sourceforge.net/project/schemaspygui/schemaspygui/SchemaSpyGUI%20Version%20$pkgver%20%2820090302%29%20-%20Linux%20bugfix/schemaSpyGUI20090302.zip")
+md5sums=('997be6c1c5d7ce83dcce6a94380deeee')
+
+build() {
+ msg2 "Generate desktop application entry..."
+ cat > "${srcdir}"/${pkgname}.desktop << EOF
+[Desktop Entry]
+Version=${pkgver}
+Encoding=UTF-8
+Name=SchemaSpyGUI
+Comment=${pkgdesc}
+Exec=/usr/bin/${pkgname}
+Terminal=false
+Type=Application
+Categories=Development;
+EOF
+
+ msg2 "Generate start script..."
+ echo "#!/bin/bash" > "${srcdir}"/${pkgname}
+ echo "java -jar /opt/${pkgname}/schemaSpyGUI.jar" '$@' >> "${srcdir}"/${pkgname}
+}
+
+package() {
+ msg2 "Installing the assembly at /opt/${pkgname}..."
+ install -dm755 "${pkgdir}"/opt/${pkgname}
+ cp -a "${srcdir}"/* "${pkgdir}"/opt/${pkgname}
+
+ msg2 "Installing the start script in /usr/bin..."
+ install -dm755 "${pkgdir}"/usr/bin/
+ install -m755 "${srcdir}"/${pkgname} "${pkgdir}"/usr/bin/${pkgname}
+
+ msg2 "Installing the desktop application entry in /usr/share/applications..."
+ install -Dm644 "${srcdir}"/${pkgname}.desktop "${pkgdir}"/usr/share/applications/${pkgname}.desktop
+}
diff --git a/schemaspygui.install b/schemaspygui.install
new file mode 100644
index 000000000000..1f1acc3d55ab
--- /dev/null
+++ b/schemaspygui.install
@@ -0,0 +1,9 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+# vim:set ts=2 sw=2 et: