summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Kessler2015-09-10 19:33:23 -0400
committerNathan Kessler2015-09-10 19:33:23 -0400
commit352e51ea24e44027ed563e3da7996042e20215f2 (patch)
treee83f3043d73365647f070127d758c517b9df55fb
downloadaur-scheme48.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD47
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf76c57f5777
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by makepkg 4.2.1
+# Thu Sep 10 23:22:49 UTC 2015
+pkgbase = scheme48
+ pkgdesc = Scheme interpreter for experimentation
+ pkgver = 1.9.2
+ pkgrel = 1
+ epoch = 0
+ url = http://s48.org/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = sh
+ source = http://s48.org/1.9.2/scheme48-1.9.2.tgz
+ md5sums = 7a869c794ca7f67ea69e98a4f2fbd7b2
+
+pkgname = scheme48
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd32580442c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Nathan Kessler <nathant93 <at> gmail.com>
+pkgname=scheme48
+pkgver=1.9.2
+pkgrel=1
+epoch=0
+pkgdesc="Scheme interpreter for experimentation"
+arch=('i686' 'x86_64')
+url="http://s48.org/"
+license=('custom')
+groups=()
+depends=()
+makedepends=(sh)
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("http://s48.org/${pkgver}/scheme48-${pkgver}.tgz")
+noextract=()
+md5sums=('7a869c794ca7f67ea69e98a4f2fbd7b2')
+validpgpkeys=()
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}