summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTércio Martins2018-08-09 02:58:40 -0300
committerTércio Martins2018-08-09 02:58:40 -0300
commitfc015fb352a7dc10a8d344970796d31078718100 (patch)
tree2100c306e7a0039fa5bae5a9e156d9dcec5d48e7
parent228b89d547e054f3e873e22b869edc85c34a8df3 (diff)
downloadaur-fc015fb352a7dc10a8d344970796d31078718100.tar.gz
Including missing dependency (python) and adding category AudioVideo in the schism.desktop file.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ebc990ade0d..bcbd80610f3f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = schismtracker
pkgdesc = A reimplementation of the Impulse Tracker music editor.
pkgver = 20180513
- pkgrel = 1
+ pkgrel = 2
url = http://schismtracker.org/
arch = i686
arch = x86_64
arch = armv7h
license = GPL
makedepends = git
+ makedepends = python
depends = sdl
depends = gcc-libs
depends = libxv
diff --git a/PKGBUILD b/PKGBUILD
index 52602262ccf8..1587b213b26a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,23 @@
pkgname=schismtracker
pkgver=20180513
-pkgrel=1
+pkgrel=2
pkgdesc='A reimplementation of the Impulse Tracker music editor.'
arch=('i686' 'x86_64' 'armv7h') # and probably other ARMs
url='http://schismtracker.org/'
license=('GPL')
depends=('sdl' 'gcc-libs' 'libxv')
-makedepends=('git')
+makedepends=('git' 'python')
conflicts=('schismtracker-git')
source=("$pkgname::git+https://github.com/schismtracker/schismtracker.git#tag=$pkgver")
md5sums=('SKIP')
+prepare () {
+ # Correcting the file "schism.desktop"
+ cd $srcdir/$pkgname/sys/fd.org
+ sed -i 's/Audio;/AudioVideo;Audio;/' schism.desktop
+}
+
build() {
cd $pkgname
autoreconf -i