summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Pacner2015-06-13 22:45:59 +0200
committerJan Pacner2015-06-13 22:45:59 +0200
commited2d6976b85d5e52bc82e626e3a17ef6a2dd6419 (patch)
tree544bc669364efaf6b5d6e9f8825bb8d094b0ffd8
downloadaur-scholdoc-static-bin.tar.gz
add: PKGBUILD
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b262e00628ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = scholdoc-static-bin
+ pkgdesc = Conversion between markup formats including ScholarlyMarkdown (no Haskell libraries)
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = http://scholarlymarkdown.com/
+ arch = x86_64
+ license = GPL
+ depends = gmp
+ depends = zlib
+ optdepends = texlive-science: for PDF creation (avoid LaTeX Error: File `algorithm.sty' not found)
+ provides = scholdoc
+ replaces = scholdoc
+ options = strip
+ source = http://scholarlymarkdown.com/scholdoc-distribution/linux/scholdoc-0.1.3-ubuntu14.tgz
+ md5sums = ab73a83b5bfe2102ebf3ce59aea765ac
+
+pkgname = scholdoc-static-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..281ffe5e2bf1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: dumblob <dumblob@gmail.com>
+# Contributor: dumblob <dumblob@gmail.com>
+# Based on pandoc-static
+
+_pkgname=scholdoc
+pkgname=${_pkgname}-static-bin
+pkgver=0.1.3
+pkgrel=1
+pkgdesc='Conversion between markup formats including ScholarlyMarkdown (no Haskell libraries)'
+url='http://scholarlymarkdown.com/'
+license=('GPL')
+
+replaces=("$_pkgname")
+provides=("$_pkgname")
+
+arch=('x86_64')
+depends=('gmp' 'zlib')
+# 'texlive-most: for PDF creation'
+optdepends=(
+ "texlive-science: for PDF creation (avoid LaTeX Error: File \`algorithm.sty' not found)"
+)
+options=(strip)
+source=("http://scholarlymarkdown.com/scholdoc-distribution/linux/${_pkgname}-${pkgver}-ubuntu14.tgz")
+md5sums=('ab73a83b5bfe2102ebf3ce59aea765ac')
+
+package() {
+ mkdir -p "$pkgdir/usr/bin/"
+ mv "$srcdir/${_pkgname}" "$pkgdir/usr/bin/"
+ mv "$srcdir/${_pkgname}-citeproc" "$pkgdir/usr/bin/"
+
+ # FIXME add some manuals
+ #install -Dm644 {,"$pkgdir"/usr/share/}man/man1/${_pkgname}.1
+ #install -Dm644 {,"$pkgdir"/usr/share/}man/man5/${_pkgname}_markdown.5
+}