summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarcan1s2015-06-08 19:57:03 +0300
committerarcan1s2015-06-08 19:57:03 +0300
commitdf37cf0b12652ba0a7d1c6cf89b40cf711940cec (patch)
treea6de47055baceea0bc0e9222fa8b350c9caab166
downloadaur-df37cf0b12652ba0a7d1c6cf89b40cf711940cec.tar.gz
upload scidavis
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD53
-rw-r--r--scidavis-python.patch68
-rw-r--r--scidavis-qtassistant.patch12
-rw-r--r--scidavis-qwt5.patch12
-rw-r--r--scidavis.install11
6 files changed, 187 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4709e4d1d3e6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = scidavis
+ pkgdesc = Application for Scientific Data Analysis and Visualization, fork of QtiPlot
+ pkgver = 1.D8
+ pkgrel = 3
+ url = http://scidavis.sourceforge.net/
+ install = scidavis.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = boost
+ makedepends = cmake
+ depends = gsl
+ depends = glu
+ depends = mesa
+ depends = muparser
+ depends = python2-pyqt4
+ depends = shared-mime-info
+ depends = qt-assistant-compat
+ depends = qwt5
+ depends = qwtplot3d
+ source = http://prdownloads.sourceforge.net/sourceforge/scidavis/scidavis.1.D8.tar.gz
+ source = scidavis-python.patch
+ source = scidavis-qtassistant.patch
+ source = scidavis-qwt5.patch
+ md5sums = c421b6a38f5183780bdf6c5960d92df5
+ md5sums = 0fefd6afe2fbc69b5faadd1112e79d7f
+ md5sums = b35c4fcbc22ca981a1679ae571ab3bed
+ md5sums = 749297643799f48527178bdb43ad94e7
+
+pkgname = scidavis
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..34e523084d23
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Evgeniy Alekseev <arcanis at archlinux dot org>
+# Contributor: Knut Franke <Knut.Franke ad gmx dot de>
+# Contributor: Olaf Leidinger <leidola at newcon dot de>
+# Contributor: Robal <nigrantis.tigris at gmail dot com>
+# Contributor: Alexander <chronischzuspaet at gmail dot com> Kempen
+
+pkgname=scidavis
+pkgver=1.D8
+pkgrel=3
+pkgdesc="Application for Scientific Data Analysis and Visualization, fork of QtiPlot"
+arch=('i686' 'x86_64')
+url="http://scidavis.sourceforge.net/"
+license=('GPL')
+makedepends=('boost' 'cmake')
+depends=('gsl' 'glu' 'mesa' 'muparser' 'python2-pyqt4' 'shared-mime-info'
+ 'qt-assistant-compat' 'qwt5' 'qwtplot3d')
+source=(http://prdownloads.sourceforge.net/sourceforge/scidavis/${pkgname}.${pkgver}.tar.gz
+ scidavis-python.patch
+ scidavis-qtassistant.patch
+ scidavis-qwt5.patch)
+install=${pkgname}.install
+md5sums=('c421b6a38f5183780bdf6c5960d92df5'
+ '0fefd6afe2fbc69b5faadd1112e79d7f'
+ 'b35c4fcbc22ca981a1679ae571ab3bed'
+ '749297643799f48527178bdb43ad94e7')
+
+prepare() {
+ cd "${srcdir}"
+ # python patch
+ patch -p0 -i "${srcdir}/scidavis-python.patch"
+ # fix qtassistant
+ patch -p0 -i "${srcdir}/scidavis-qtassistant.patch"
+ # fix qwt
+ patch -p0 -i "${srcdir}/scidavis-qwt5.patch"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}.${pkgver}"
+ qmake-qt4
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}.${pkgver}"
+ make INSTALL_ROOT="${pkgdir}" DESTDIR="${pkgdir}" install
+
+ _pydir=$(python2 -c "from distutils import sysconfig; print sysconfig.get_python_lib()")
+ python2 $(dirname ${_pydir})/py_compile.py "${pkgdir}/etc/scidavisrc.py"
+ python2 $(dirname ${_pydir})/py_compile.py "${pkgdir}/usr/share/scidavis/scidavisUtil.py"
+
+ # remove liborigin files since it uses static library
+ rm -rf "${pkgdir}/usr/local"
+}
diff --git a/scidavis-python.patch b/scidavis-python.patch
new file mode 100644
index 000000000000..2d797e8bb65f
--- /dev/null
+++ b/scidavis-python.patch
@@ -0,0 +1,68 @@
+diff -ruN scidavis.1.D8.orig/scidavis/python-includepath.py scidavis.1.D8/scidavis/python-includepath.py
+--- scidavis.1.D8.orig/scidavis/python-includepath.py 2014-07-22 12:01:44.000000000 +0400
++++ scidavis.1.D8/scidavis/python-includepath.py 2014-07-23 11:29:57.651838033 +0400
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python2
+
+ ############################################################################
+ # #
+@@ -28,6 +28,4 @@
+ ############################################################################
+
+ from distutils import sysconfig
+-from PyQt4 import pyqtconfig
+-config = pyqtconfig.Configuration()
+-print " ".join([sysconfig.get_python_inc(), config.sip_inc_dir])
++print sysconfig.get_python_inc()
+diff -ruN scidavis.1.D8.orig/scidavis/python-sipcmd.py scidavis.1.D8/scidavis/python-sipcmd.py
+--- scidavis.1.D8.orig/scidavis/python-sipcmd.py 2014-07-22 12:01:44.000000000 +0400
++++ scidavis.1.D8/scidavis/python-sipcmd.py 2014-07-23 11:39:18.501823204 +0400
+@@ -27,10 +27,6 @@
+ # #
+ ############################################################################
+
+-from PyQt4 import pyqtconfig
+-config = pyqtconfig.Configuration()
+ flags = ["-I ../scidavis"]
+-if config.sip_version >= 0x040a00:
+- # make use of docstring generation feature in SIP >= 4.10
+- flags.append("-o")
+-print " ".join([config.sip_bin, "-I", config.pyqt_sip_dir, config.pyqt_sip_flags] + flags)
++flags.append("-o")
++print " ".join(["/usr/bin/sip", "-I", "/usr/share/sip/PyQt4", "-x VendorID -t WS_X11 -t Qt_4_8_6 -x Py_v3"] + flags)
+diff -ruN scidavis.1.D8.orig/scidavis/python.pri scidavis.1.D8/scidavis/python.pri
+--- scidavis.1.D8.orig/scidavis/python.pri 2014-07-22 12:01:44.000000000 +0400
++++ scidavis.1.D8/scidavis/python.pri 2014-07-23 11:23:28.455181657 +0400
+@@ -16,19 +16,19 @@
+ SOURCES += ../scidavis/src/PythonScript.cpp ../scidavis/src/PythonScripting.cpp
+
+ unix {
+- INCLUDEPATH += $$system(python python-includepath.py)
++ INCLUDEPATH += $$system(python2 python-includepath.py)
+ contains(PRESET,mac_dist) {
+ DEFINES += PYTHONHOME=/Applications/scidavis.app/Contents/Resources
+ } else {
+ macx {
+ LIBS += -framework Python
+ } else {
+- LIBS += $$system(python -c "\"from distutils import sysconfig; print '-lpython'+sysconfig.get_config_var('VERSION')\"")
++ LIBS += $$system(python2 -c "\"from distutils import sysconfig; print '-lpython'+sysconfig.get_config_var('VERSION')\"")
+ }
+ }
+ LIBS += -lm
+ system(mkdir -p $${SIP_DIR})
+- system($$system(python python-sipcmd.py) -c $${SIP_DIR} ../scidavis/src/scidavis.sip)
++ system($$system(python2 python-sipcmd.py) -c $${SIP_DIR} ../scidavis/src/scidavis.sip)
+ }
+
+ win32 {
+@@ -36,7 +36,7 @@
+ DEFINES += SIP_STATIC_MODULE
+ # QMAKE_LIBPATH += "$$(HOME)/usr/mxe/PyQt4/"
+ LIBS += -L"$$(HOME)/usr/mxe/PyQt4/" -lPyQtCore -lPyQtGui -lqpygui -lqpycore -lsip -lpython27
+- system($$system(python python-sipcmd.py) -c $${SIP_DIR} src/scidavis.sip)
++ system($$system(python2 python-sipcmd.py) -c $${SIP_DIR} src/scidavis.sip)
+ } else {
+ INCLUDEPATH += $$system(call python-includepath.py)
+ LIBS += $$system(call python-libs-win.py)
diff --git a/scidavis-qtassistant.patch b/scidavis-qtassistant.patch
new file mode 100644
index 000000000000..60c182bdfaa3
--- /dev/null
+++ b/scidavis-qtassistant.patch
@@ -0,0 +1,12 @@
+diff -ruN scidavis.1.D8.orig/scidavis/src/ApplicationWindow.cpp scidavis.1.D8/scidavis/src/ApplicationWindow.cpp
+--- scidavis.1.D8.orig/scidavis/src/ApplicationWindow.cpp 2014-07-22 12:01:44.000000000 +0400
++++ scidavis.1.D8/scidavis/src/ApplicationWindow.cpp 2014-07-23 09:18:28.882046613 +0400
+@@ -143,7 +143,7 @@
+ #include <QList>
+ #include <QUrl>
+ #ifndef NOASSISTANT
+-#include <QtAssistant/QAssistantClient>
++#include <QtAssistant/qassistantclient.h>
+ #endif
+ #include <QStatusBar>
+ #include <QToolButton>
diff --git a/scidavis-qwt5.patch b/scidavis-qwt5.patch
new file mode 100644
index 000000000000..63eadfefdc23
--- /dev/null
+++ b/scidavis-qwt5.patch
@@ -0,0 +1,12 @@
+diff -ruN scidavis.1.D8.orig/config.pri scidavis.1.D8/config.pri
+--- scidavis.1.D8.orig/config.pri 2014-07-22 12:01:44.000000000 +0400
++++ scidavis.1.D8/config.pri 2014-07-23 10:29:36.111933787 +0400
+@@ -261,7 +261,7 @@
+ } else {
+ INCLUDEPATH += /usr/include/qwt$${qwtsuff}
+ }
+- LIBS += -lqwt$${qwtsuff} -lz -lGLU -lQtAssistantClient
++ LIBS += -lqwt5 -lz -lGLU -lQtAssistantClient
+
+ INCLUDEPATH += /usr/include/qwtplot3d$${qwtsuff}
+ LIBS += -lqwtplot3d$${qwtsuff}
diff --git a/scidavis.install b/scidavis.install
new file mode 100644
index 000000000000..83c6997c5910
--- /dev/null
+++ b/scidavis.install
@@ -0,0 +1,11 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor 2> /dev/null
+ update-desktop-database -q
+ update-mime-database /usr/share/mime/ > /dev/null
+}
+
+post_remove() {
+ post_install $1
+}
+
+# vim:set ts=2 sw=2 et: