summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBatuhan Başerdem2022-08-17 00:18:58 -0500
committerBatuhan Başerdem2022-08-17 00:18:58 -0500
commit0ea5e720a82efe18815c340f3ec5f35d0c4cf067 (patch)
tree25e25bd97427d0ff6f5e6d07fbad9dd18c1b52f9
parent0d9a6bace6077f39cf16036c01f11c5cf6ee5429 (diff)
downloadaur-0ea5e720a82efe18815c340f3ec5f35d0c4cf067.tar.gz
Initial commit after deletion
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD86
-rw-r--r--scientifica-font.install21
3 files changed, 47 insertions, 86 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d230d3885546..d535a275e220 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,19 @@
pkgbase = scientifica-font
pkgdesc = Tall and condensed bitmap font for geeks.
- pkgver = 1.0.1
+ pkgver = 2.3
pkgrel = 1
url = https://github.com/NerdyPepper/scientifica
- install = scientifica-font.install
arch = any
- license = SIL
- depends = xorg-fonts-encodings
- depends = xorg-font-utils
- depends = fontconfig
- optdepends = xorg-fonts-alias
- source = https://raw.githubusercontent.com/NerdyPepper/scientifica/master/regular/scientifica-11.bdf
- source = https://raw.githubusercontent.com/NerdyPepper/scientifica/master/bold/scientificaBold-11.bdf
- source = https://raw.githubusercontent.com/NerdyPepper/scientifica/master/LICENSE
- md5sums = d5c103c0e65fa0b3cf594e762a759d8d
- md5sums = 0965772b2f69aeec0d2f60194a167fc0
- md5sums = 77b104b57cdfb5a0e62b76a0057009df
+ license = OFL
+ provides = ttf-scientifica
+ provides = otb-scientifica
+ conflicts = scientifica-ttf
+ conflicts = scientifica-otb
+ conflicts = ttf-scientifica
+ conflicts = otb-scientifica
+ source = scientifica.tar::https://github.com/NerdyPepper/scientifica/releases/download/v2.3/scientifica.tar
+ source = scientifica-2.3.tar.gz::https://github.com/NerdyPepper/scientifica/archive/refs/tags/v2.3.tar.gz
+ sha256sums = f0857869a0e846c6f175dcb853dd1f119ea17a75218e63b7f0736d5a8e1e8a7f
+ sha256sums = 00ab57863c3004c5e2148426ef87649cffe66ed240a49b82243ca8916a2da096
pkgname = scientifica-font
-
diff --git a/PKGBUILD b/PKGBUILD
index 389eb65e91fd..a29b4858a596 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,54 +1,38 @@
-# Maintainer: Harry Law <h@lsf.pw>
-# Contributor: Savino Jossi <savino.jossi@gmail.com>
-
-pkgname=scientifica-font
-pkgver=1.0.6
-pkgrel=2
-pkgdesc='Tall and condensed bitmap font for geeks.'
-license=('SIL')
+# Maintainer: Batuhan Baserdem <last.first@gmail.com>
+name='scientifica'
+pkgname="${name}-font"
+pkgver='2.3'
+pkgrel=1
+pkgdesc="Tall and condensed bitmap font for geeks."
+url="https://github.com/NerdyPepper/${name}"
+license=('OFL')
+source=(
+ "${name}.tar::${url}/releases/download/v${pkgver}/${name}.tar"
+ "${name}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz"
+)
+sha256sums=(
+ 'f0857869a0e846c6f175dcb853dd1f119ea17a75218e63b7f0736d5a8e1e8a7f'
+ '00ab57863c3004c5e2148426ef87649cffe66ed240a49b82243ca8916a2da096'
+)
arch=('any')
-url='https://github.com/NerdyPepper/scientifica'
-depends=('xorg-fonts-encodings' 'xorg-font-utils' 'fontconfig')
-optdepends=('xorg-fonts-alias')
-install=scientifica-font.install
-_rawlink='https://raw.githubusercontent.com/NerdyPepper/scientifica/'
-source=("${_rawlink}master/regular/scientifica-11.bdf"
- "${_rawlink}master/bold/scientificaBold-11.bdf"
- "${_rawlink}master/LICENSE")
-md5sums=('d5c103c0e65fa0b3cf594e762a759d8d'
- '0965772b2f69aeec0d2f60194a167fc0'
- '77b104b57cdfb5a0e62b76a0057009df')
-
-build(){
- msg2 "Creating font config file..."
- cat << EOF > 75-yes-scientifica.conf
-<?xml version="1.0"?>
-<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
-<fontconfig>
-<!-- Accept scientifica font -->
- <selectfont>
- <acceptfont>
- <pattern>
- <patelt name="family"><string>Scientifica</string></patelt>
- </pattern>
- </acceptfont>
- </selectfont>
-</fontconfig>
-EOF
-}
-
+conflicts=(
+ "${name}-ttf"
+ "${name}-otb"
+ "ttf-${name}"
+ "otb-${name}"
+)
+provides=(
+ "ttf-${name}"
+ "otb-${name}"
+)
package() {
- msg2 "Installing bitmap font files..."
- install -Dm0644 scientifica-11.bdf \
- "${pkgdir}/usr/share/fonts/misc/scientifica-11.bdf"
- install -Dm0644 scientificaBold-11.bdf \
- "${pkgdir}/usr/share/fonts/misc/scientificaBold-11.bdf"
-
- msg2 "Installing font config files..."
- install -Dm0644 75-yes-scientifica.conf \
- "${pkgdir}/etc/fonts/conf.avail/75-yes-scientifica"
-
- msg2 "Installing license..."
- install -Dm0644 LICENSE \
- "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ # Install the TrueType fonts
+ install -D --mode=644 "${srcdir}/${name}/ttf/${name}"*.ttf \
+ --target-directory "${pkgdir}/usr/share/fonts/TTF"
+ # Install the OpenType bitmap fonts
+ install -D --mode=644 "${srcdir}/${name}/otb/${name}"*.otb \
+ --target-directory "${pkgdir}/usr/share/fonts/misc"
+ # Install the license
+ install -D --mode=644 "${srcdir}/${name}-${pkgver}/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/scientifica-font.install b/scientifica-font.install
deleted file mode 100644
index 66d3d2229660..000000000000
--- a/scientifica-font.install
+++ /dev/null
@@ -1,21 +0,0 @@
-_cache() {
- echo "Updating font cache..."
- fc-cache -vfs
- mkfontscale /usr/share/fonts/misc
- mkfontdir /usr/share/fonts/misc
-}
-
-post_install() {
- echo "Enabling fontconfig files..."
- ln -fs -t /etc/fonts/conf.d/ /etc/fonts/conf.avail/70-yes-bitmaps.conf
- ln -fs -t /etc/fonts/conf.d/ /etc/fonts/conf.avail/75-yes-scientifica.conf
- _cache
-}
-
-post_upgrade() {
- post_install ${1}
-}
-
-post_remove() {
- _cache
-}