summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrançois Boulogne2015-08-02 16:30:10 -0400
committerFrançois Boulogne2015-08-02 16:30:10 -0400
commit4508d657f4cae64865e1e904151941675960b45f (patch)
tree25e4757dfd999c8176418688b72411e6d3380260
downloadaur-4508d657f4cae64865e1e904151941675960b45f.tar.gz
start package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1305fedbf61a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = scifig
+ pkgdesc = A build tool for (non?)-scientific figures
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://scifig.readthedocs.org/
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python
+ source = https://pypi.python.org/packages/source/s/scifig/scifig-0.1.tar.gz
+ sha256sums = f2fe58ee3e693d91c38f8535ef52c803bf8e3f831728304c744b2bf0b2e5eca0
+
+pkgname = scifig
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..560018c03d4a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Francois Boulogne <fboulogne at april dot org>
+# Maintainer: Francois Boulogne <fboulogne at april dot org>
+
+pkgname=scifig
+pkgver=0.1
+pkgrel=1
+pkgdesc="A build tool for (non?)-scientific figures"
+arch=('any')
+url="https://scifig.readthedocs.org/"
+license=('GPL3')
+depends=('python')
+makedepends=('python-setuptools')
+source=(https://pypi.python.org/packages/source/s/scifig/scifig-${pkgver}.tar.gz)
+sha256sums=('f2fe58ee3e693d91c38f8535ef52c803bf8e3f831728304c744b2bf0b2e5eca0')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
+}
+
+package(){
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:ts=2:sw=2:et: