summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreolianoe2018-01-04 17:14:05 +0100
committereolianoe2018-01-04 17:14:05 +0100
commit16e0134dac5001906128e019a131ba64042044ee (patch)
treeef90a2ed3d6627abfc69d1514ad119f2a32d4c6e
parent05cc067bb05e1a65263d83432e71e15c790d6300 (diff)
downloadaur-16e0134dac5001906128e019a131ba64042044ee.tar.gz
fix for apache lucene>=7
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--scilab-lucene-6.patch11
-rw-r--r--scilab-lucene.patch36
4 files changed, 47 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad6bee16ae88..307ef502e29e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Oct 2 20:35:17 UTC 2017
+# Thu Jan 4 16:13:59 UTC 2018
pkgbase = scilab
pkgdesc = A scientific software package for numerical computations.
pkgver = 6.0.0
- pkgrel = 11
+ pkgrel = 12
url = https://www.scilab.org
arch = i686
arch = x86_64
@@ -42,14 +42,14 @@ pkgbase = scilab
depends = xalan-java
depends = docbook-xsl
depends = jogl>=2.3.2
- depends = apache-lucene>=6
+ depends = apache-lucene>=7
depends = java-batik>=1.8
depends = java-xmlgraphics-commons>=2.0
source = https://www.scilab.org/download/6.0.0/scilab-6.0.0-src.tar.gz
source = scilab-jogl-2.3.2.patch
source = scilab-LD_LIBRARY_PATH.patch
source = scilab-strict-jar.patch
- source = scilab-lucene-6.patch
+ source = scilab-lucene.patch
source = scilab-hdf5-type.patch
source = scilab-hdf5-1.8.10.patch
source = scilab-fix-ocaml-4.0.4.diff
@@ -59,7 +59,7 @@ pkgbase = scilab
sha256sums = f19f173e989f72bd55bda35e271b3c180ecef4e29da964df3f230fce8b1330fc
sha256sums = 37f649fea0196b255e5a8576dd1e8c5fd219c6e8c600b703b35303fb90b6a7e0
sha256sums = 38aa094951338fa1d267dc6f397552e175213b0f8ba7b35727c178607861f6dd
- sha256sums = ba7969fff7f839562120534222fbb6421e204f6a382654d80bbab19e0c7a2c66
+ sha256sums = b1fb3e4b08b3c17f267c213d954c704cb95225cf1445cf92892e205a4ca14d76
sha256sums = c992a4f230dac60c3e217efee04b678c58d856f2aafa6173f742d4c5b050ab9d
sha256sums = 2dee1346c240d09ce7870bbbeb3318e0ac5d78f249d855df313e9cb7a2ef7fc0
sha256sums = 4288f98e34d0351c21b79bfc5b9fddabdee143965420fd3187d133e5d53ee20e
diff --git a/PKGBUILD b/PKGBUILD
index 588f3a1d0d0b..5368e2247a10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=scilab
pkgver=6.0.0
-pkgrel=11
+pkgrel=12
pkgdesc='A scientific software package for numerical computations.'
arch=('i686' 'x86_64')
url='https://www.scilab.org'
@@ -18,14 +18,14 @@ depends=('suitesparse>=4.4.1' 'arpack' 'fftw' 'eigen'
'jeuclid-core' 'jgraphx>=2.0.0.1' 'javahelp2'
'saxon-he' 'jlatexmath-fop>=1.0.3' 'jrosetta>=1.0.4' 'jgoodies-looks' 'java-qdox'
'java-skinlf' 'java-testng' 'xalan-java' 'docbook-xsl'
- 'jogl>=2.3.2' 'apache-lucene>=6'
+ 'jogl>=2.3.2' 'apache-lucene>=7'
'java-batik>=1.8' 'java-xmlgraphics-commons>=2.0')
makedepends=('java-environment>=8' 'apache-ant' 'ocaml' 'gcc-fortran' )
source=("${url}/download/${pkgver}/${pkgname}-${pkgver}-src.tar.gz"
"${pkgname}-jogl-2.3.2.patch"
"${pkgname}-LD_LIBRARY_PATH.patch"
"${pkgname}-strict-jar.patch"
- "${pkgname}-lucene-6.patch"
+ "${pkgname}-lucene.patch"
"${pkgname}-hdf5-type.patch"
"${pkgname}-hdf5-1.8.10.patch"
"${pkgname}-fix-ocaml-4.0.4.diff"
@@ -35,7 +35,7 @@ sha256sums=('b71bde8e397173a713493159a5b559de2e049b493985663418c79b2de0f23137'
'f19f173e989f72bd55bda35e271b3c180ecef4e29da964df3f230fce8b1330fc'
'37f649fea0196b255e5a8576dd1e8c5fd219c6e8c600b703b35303fb90b6a7e0'
'38aa094951338fa1d267dc6f397552e175213b0f8ba7b35727c178607861f6dd'
- 'ba7969fff7f839562120534222fbb6421e204f6a382654d80bbab19e0c7a2c66'
+ 'b1fb3e4b08b3c17f267c213d954c704cb95225cf1445cf92892e205a4ca14d76'
'c992a4f230dac60c3e217efee04b678c58d856f2aafa6173f742d4c5b050ab9d'
'2dee1346c240d09ce7870bbbeb3318e0ac5d78f249d855df313e9cb7a2ef7fc0'
'4288f98e34d0351c21b79bfc5b9fddabdee143965420fd3187d133e5d53ee20e'
@@ -51,8 +51,8 @@ prepare(){
patch -p2 < "${srcdir}"/${pkgname}-jogl-2.3.2.patch
# Linked to: https://codereview.scilab.org/#/c/18089/
patch < "${srcdir}"/${pkgname}-strict-jar.patch
- # Fix to build with lucene >= 6
- patch -p0 < "${srcdir}"/${pkgname}-lucene-6.patch
+ # Fix to build with lucene >= 7
+ patch -p0 < "${srcdir}"/${pkgname}-lucene.patch
# Fix hdf5 type
patch -p0 < "${srcdir}"/${pkgname}-hdf5-type.patch
# Fix for LD_LIBRARY_PATH
diff --git a/scilab-lucene-6.patch b/scilab-lucene-6.patch
deleted file mode 100644
index 7054a6876c91..000000000000
--- a/scilab-lucene-6.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- modules/xcos/src/java/org/scilab/modules/xcos/palette/PaletteSearcher.java 2017-02-15 19:48:09.065311738 +0100
-+++ modules/xcos/src/java/org/scilab/modules/xcos/palette/PaletteSearcher.java.new 2017-02-15 19:43:03.057878902 +0100
-@@ -52,7 +52,7 @@
- */
- public List<Document> search(String str) {
- List<Document> found = new ArrayList<>();
-- try (IndexReader reader = DirectoryReader.open(mgr.getIndexWriter(), true)) {
-+ try (IndexReader reader = DirectoryReader.open(mgr.getIndexWriter(), true, true)) {
- IndexSearcher searcher = new IndexSearcher(reader);
-
- StandardQueryParser queryParserHelper = new StandardQueryParser();
diff --git a/scilab-lucene.patch b/scilab-lucene.patch
new file mode 100644
index 000000000000..14ba0b55ce28
--- /dev/null
+++ b/scilab-lucene.patch
@@ -0,0 +1,36 @@
+--- modules/xcos/src/java/org/scilab/modules/xcos/palette/PaletteSearcher.java 2017-02-15 19:48:09.065311738 +0100
++++ modules/xcos/src/java/org/scilab/modules/xcos/palette/PaletteSearcher.java.new 2017-02-15 19:43:03.057878902 +0100
+@@ -52,7 +52,7 @@
+ */
+ public List<Document> search(String str) {
+ List<Document> found = new ArrayList<>();
+- try (IndexReader reader = DirectoryReader.open(mgr.getIndexWriter(), true)) {
++ try (IndexReader reader = DirectoryReader.open(mgr.getIndexWriter())) {
+ IndexSearcher searcher = new IndexSearcher(reader);
+
+ StandardQueryParser queryParserHelper = new StandardQueryParser();
+@@ -57,7 +57,6 @@
+
+ StandardQueryParser queryParserHelper = new StandardQueryParser();
+ queryParserHelper.setAllowLeadingWildcard(true);
+- queryParserHelper.setLowercaseExpandedTerms(true);
+ queryParserHelper.setAnalyzer(mgr.getAnalyzer());
+ queryParserHelper.setMultiFields(new String[] {"refname", "refpurpose", "content"});
+
+--- modules/xcos/src/java/org/scilab/modules/xcos/palette/PaletteIndexer.java 2018-01-04 15:55:54.019390755 +0100
++++ modules/xcos/src/java/org/scilab/modules/xcos/palette/PaletteIndexer.java.new 2018-01-04 15:56:08.879485713 +0100
+@@ -162,7 +162,6 @@
+
+ // add the block name
+ Field refname = new TextField("refname", basename, Field.Store.YES);
+- refname.setBoost(100f);
+ doc.add(refname);
+
+ // add the refpurpose
+@@ -176,7 +175,6 @@
+ refpurpose = new TextField("refpurpose", "", Field.Store.YES);
+ }
+
+- refpurpose.setBoost(10f);
+ doc.add(refpurpose);
+ }